Can't get overclocking activated with coolbits "1" for nvidia settings (Geforce 210/ Xubun


I’m pretty new to Linux and I fresh installed a Xubuntu 16.04 (64 bit) on my Computer. I’m using a Geforce 210 and installed the suggested driver 340.96 via the “additional drivers” window. The nvidia drivers download page tells me that this is the correct version for my card.

I opened /etc/X11/xorg.conf as root and added

Option "Coolbits" "1"

in the “Device section”, but that didn’t give me the “Clock Frequencies” Option in nvidia settings. I also tried

sudo nvidia-xconfig --cool-bits=1

but that didn’t work as well. However, using the value “4” for coolbits works, but I’m rather interested in configuring the clock than the fan, like I did under Windows.

In my post in ubuntuusers forum it was mentioned, that maybe the whole option was dropped by nvidia at some point.

So my question is, am I doing something wrong? Or is this feature really not available - with this driver/ for any driver?

Thanks for your attention.

Hopefully helpful informations:

$ lspci -nnk | grep "VGA\|'Kern'\|3D\|Display" -A2
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GT218 [GeForce 210] [10de:0a65] (rev a2)
	Subsystem: Corp. GT218 [GeForce 210] [3842:1313]
	Kernel driver in use: nvidia

Link to my nvidia-bug-report.log.gz, since I can’t find an attachement button here.

I use Coolbits 5 for that card.

I’m on driver version 304.x though.

On some cards it is disabled, though, such as those that come with a factory overclock.

Thanks for your reply. I checked my video card and found that it is indeed factory overclocked. I was already looking for a new card but then just tried the whole thing with installing Xubuntu 14.04. And it worked with both, the nvidia-304 and the nvidia-340 driver. Crazy.

Back with a fresh install of Xubuntu 16.04, just to be extra sure, I checked again with the 304-driver and it still refuses to cooperate.

Something seems to be different between this two versions.

I don’t know if this is relevant, additionaly I noticed that in contrast to the 16.04 Version, under 14.04

  1. I don’t get a “Unknown Device” displayed at “Additional Drivers”, for that a
Processor microcode firmware for Intel CPUs by intel-microcode

is available

  1. on bootscreen, after the installation of the nvidia driver, there is not the previous used warning
[    1.624070] tpm_tis 00:00: TPM error (7) attempting to read a pcr value


  1. I don’t have to resynchronise the time in Windows, after rebooting from Xubuntu.

I already looked up wikipedia for TPM, but I thought it is more an “optional feature” and wouldn’t be relevant for this issue. In my BIOS, TPM was and is disabled.

Is there anything interesting in /var/log/Xorg.0.log?

I haven’t upgraded to 16.04 yet but it would be weird if something in the OS was causing the issue.

I don’t know what I have to look for in the Xorg.0.log, but I just pasted the whole file and maybe you can see something important? Sorry, I’m really doing my first serious steps with Linux and in this OS.



not sure if this is relevant, but gpu sounds like video card related, so I copied that too

I don’t see anything wrong there. It might be best to roll back to 14.04 and wait to see if others are reporting any similar problems with 16.04.

Sorry for the late reply. Thank you for your attention and advice. I am using the 14.04 version now and hopefully I can find a clue about what stops coolbits working in the recent LTS version for my video card, until the support ends.

Why you even need to be OC’ed for GT218 GeForce 210? It doesn’t give you any performance and just can possible damage your GPU. As you see in my forum info on the bottom I use OC’ed version of Asus engtx580 DCII 1536Mb and it factory OC’ed but I just edited my vBIOS of VGA card to run stock gtx580 clocs and its fine with Ubuntu 16.04 LTS. I am not even tried to enable any coolbits cause these card and probably yours has already few power states implemented on hardware level and there is no need to tweak anything cause it wasn’t go anyhow better for you and me. Just use nvidia binary driver from (tested) and you’ll be fine with that.

Thanks for your reply, zor1984. It’s a misunderstanding, I made it not clear, my bad.
I am not interested in overclocking the videocard, I want to underclock it just for when I play a game (everyday desktop usage like office and browser isn’t an issue).

I already lost a passive cooling not-overclocked geforce last summer to the heat, I simply had no clue things like this can happen. So I am more careful now. :)

I figured out the values I have to set, to keep the video card “cool” (not more than 80°C instead of 98°C+, but the summer just started) and still having good graphics support in the games I play.

I read at some sites about the possibility to manipulate the clocks somehow “directly at the video card” (probably that’s what you did?) but it looked very complicated and dangerous to me, as a not really IT-affine person.

So, that’s why I got a bit nervous that coolbits doesn’t seem to work in the latest OS versions (for me) and I tried to get a clue why it doesn’t, before I try to get a different, hopefully compatible video card.