Enabling coolbits - two 2080Ti,Ubuntu 20.04

So one of my two 2080Ti Gpus is literally going up from 40% gpu fan when the temperature is 84, to over 90% (which makes a terrible noise) at 85.

I want to setup the fan control profile so that the gpu fan will go up a little bit sooner, but as far as I can tell, i need to enable coolbits. My OS is Ubuntu 20.04.

I have tried to create a file /etc/X11/xorg.conf.d/11-nvidia-coolbits.conf
with the following contents:

Section "OutputClass"
    Identifier "nvidia"
    MatchDriver "nvidia-drm"
    Driver "nvidia"
    Option "Coolbits" "4"
EndSection

But that enables only GPU0’s coolbits (I can’t control GPU1’s fan speed through nvidia-settings while I can control GPU0).
I have tried to include

Option "AllowNVIDIAGPUScreens" "false"

but that didn’t help.
How can I enable GPU1’s coolbits?

1 Like

You can use this i guess.

Not without enabling coolbits.

I found similar conf files under a different path… recently had this working for myself on a single RTX 3090 … but when I added my GTX 1060 to the same system… only the 1060 seems to have fan control enabled…

$ cat /usr/share/X11/xorg.conf.d/10-nvidia.conf 
Section "OutputClass"
    Identifier "nvidia"
    MatchDriver "nvidia-drm"
    Driver "nvidia"
    Option "AllowEmptyInitialConfiguration"
    ModulePath "/usr/lib/x86_64-linux-gnu/nvidia/xorg"
EndSection

EDIT:

Okay I now have full fan control on two GPUS in Ubuntu 20.04… where before I had only 1… what did I do? I reran the same ol’ same command and rebooted… and voila

source : How to control Nvidia graphics card Fan Automatically in Linux | Techticity

sudo nvidia-xconfig -a --cool-bits=28 --allow-empty-initial-configuration

I didn’t even need to edit the xorg.conf after that… just reboot. Hope it helps!