GTX 1060 - Control GPU Performance Level (430.14)

Hello. I’m wondering if there’s any way to control the GPU performance level beyond either adaptive or maximum performance. Specifically, if there’s any way I can limit the performance level to 0 or 1 when I’m not doing any GPU intensive tasks. I’m using the 1060 in a laptop and even light browsing causes it to often jump to performance level 4, taking about 10-20 seconds of inactivity to drop back to performance level 0.

This makes the device I’m using get uncomfortably hot and drains the battery far quicker than ideal.

Things I have tried to no success:

Setting the power level or clock speed with nvidia SMI. Neither is supported.

These options in xorg.conf. They do nothing

Option "Coolbits" "13"
Option "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x2222; PowerMizerLevel=0x3;PowerMizerDefault=0x3; PowerMizerDefaultAC=0x3"

Changing the PowerMizer. I can only do Adaptive, Auto (which does Adaptive), or Performance.

Changing the graphics clock offset or memory transfer offset, neither can be set to the low levels that performance level 0 gives me.

Hi, I’m having the same problem, and lately is being very annoying with the fans going crazy with normal programming tasks (probably due to having slack or chrome on the background, also because I switched to a 4K monitor from a fullHD one). This is really annoying and is giving me a headhache sometimes.

So please give us an option to change this or tell us how it is done, so we can set a maximum performance for when we are not using something that needs power from the GPU.

BTW, mine is always at 4, only occasionally (very rarely and not even moving the mouse) going down to 2, and immediately moves back to 4 again.

(also answering to get updates in my email)

I’m using arch linux with a MSI dominator 17" laptop that only has the NVIDIA and does not use optimus or anything like that, connected to a 4k 32" monitor BENQ EW3270U (in case is relevant)

Driver: 450.57
linux: 5.7.10-arch1-1
WM: xfce4 (non composite)

forgot to mention my nvidia card details:
GeForce GTX 1060 6GB

Also is curious how the driver chooses highest power level with a “GPU utilization” of around 5-10% and 13% used memory.