Kernel module option NVreg_RegistryDwords for PowerMizerEnable doesnt work on 530.41.03

I’m using a 1080ti on Arch Linux.

I’ve been fighting with /etc/modprobe.d/nvidia.conf file to limit performance level to minimum.

Turns out it works fine on driver 520.56.06 but has no effect on 530.41.03.

Contents of the nvidia.conf file;
options nvidia NVreg_RegistryDwords=“PowerMizerEnable=0x1;PerfLevelSrc=0x2222;PowerMizerDefault=0x2;PowerMizerDefaultAC=0x2;PowerMizerLevel=0x2”

Same here.

Gentoo Linux
Kernel 5.15.104
X.Org 21.1.7


options nvidia \
        NVreg_RegistryDwords="PowerMizerEnable=0x1; PerfLevelSrc=0x3333; PowerMizerLevel=0x2; PowerMizerDefault=0x2; PowerMizerDefaultAC=0x2"

Worked fine with any previous driver. Clocks are low, temp never exceeds 45C and the fans stay off… With 530.41.03, the GPU clocks up to max and the fans start spinning since GPU reaches 60C pretty much all the time.

nvidia-bug-report.log.gz (337.7 KB)