[SOLVED] Forcing maximum power saving on the desktop ("Minimum power" mode for PowerMizer)

.

Why cannot NVIDIA users enforce the lowest performance level/maximum power savings on the desktop?

When I had a 8800GT GPU I simply used nvclock to power down my GPU:

nvidia-settings -a GPUOverclockingState=1 -a GPU2DClockFreqs=165,237 -a GPU3DClockFreqs=165,237
or with older drivers:
nvclock -f -m 200 -n 150

and it worked beautifully.

With Kepler overclocking is no more and we are allowed only three power unfriendly modes: Auto, Adaptive and Maximum Performance.

Please, allow us to have and use “Maximum power saving” mode on the desktop.

This issue is also discussed here - no resolution though.

I’ve found a solution, hooray!!

These features are no longer available on driver versions 340 and 346 – tested on FreeBSD. It seems like the driver no longer recognizes RegistryDWords…

Works fine for me, but with: Option “Coolbits” “13”

hi
nvidia-settings -q GPUPerfModes -t
perf=0, nvclock=590, nvclockmin=590, nvclockmax=590, nvclockeditable=0,
memclock=600, memclockmin=600, memclockmax=600, memclockeditable=0,
memTransferRate=1200, memTransferRatemin=1200, memTransferRatemax=1200,
memTransferRateeditable=0, processorclock=1405, processorclockmin=1405,
processorclockmax=1405, processorclockeditable=0
perf=0, nvclock=590, nvclockmin=590, nvclockmax=590, nvclockeditable=0,
memclock=600, memclockmin=600, memclockmax=600, memclockeditable=0,
memTransferRate=1200, memTransferRatemin=1200, memTransferRatemax=1200,
memTransferRateeditable=0, processorclock=1405, processorclockmin=1405,
processorclockmax=1405, processorclockeditable=0

only one performance mode , i am using 340.65 driver( patched version ) (G210) under Kernel 3.19 .

I am still waiting for a new update .
regards
Mounir

An update from 2020. Some users may now require a kernel module option instead of an X.org option.

cat /etc/modprobe.d/nvidia.conf
options nvidia NVreg_RegistryDwords="OverrideMaxPerf=0x1"