Can't force powermizer to the lowest level (settings always seem to get ignored)

I’m trying to force powermizer to only use level 0 for powersaving purposes, but nothing I’ve tried has worked.

So far I tried:

options nvidia NVreg_RegistryDwords="PowerMizerEnable=0x1; PowerMizerDefaultAC=0x3; PowerMizerLevelAC=0x3; PowerMizerLevel=0x3; PerfLevelSrc=0x2222;"

and alternatively

options nvidia NVreg_RegistryDwords="OverrideMaxPerf=0x1"

in /etc/modprobe.d/nvidia-user-registry.conf (and I did rebuild my initramfs ater setting these, still didn’t work)

I’ve also tried setting similar settings in /etc/X11/xorg.conf.d/10-nvidia.conf

But nothing seems to work; powermizer just keeps jumping between all levels as it pleases no matter what I do, it’s like the settings just get ignored :(

The only option that got me a reaction was the first one, the reaction was to lock powermizer to level 4 (maximum performance mode), I imagine that would be due to PerfLevelSrc=0x2222

I’m just about at my wit’s end over this issue, any help would be appreciated.

nvidia-bug-report.log.gz (266.4 KB)

System info:

$inxi --admin --verbosity=7 --filter --no-host --width
  Kernel: 5.18.17-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.18-x86_64
    root=UUID=f87ef1fe-5eec-4ec5-b98c-105742ac8e6d rw quiet
    sysrq_always_enabled=1 mitigations=off nowatchdog pci=nommconf
    cpufreq.default_governor=powersave apparmor=1 security=apparmor
    udev.log_priority=3 acpi_osi=! acpi_osi=Linux "acpi_osi=Windows 2009"
    nogpumanager intel_idle.max_cstate=1 i915.enable_gvt=1 i915-enable_fbc=1
    iommu=pt intel_iommu=on kvm.ignore_msrs=1 rd.driver.pre=vfio-pci
    default_hugepagesz=1G hugepagesz=1G hugepages=0 transparent_hugepage=never
  Desktop: KDE Plasma v: 5.24.6 tk: Qt v: 5.15.5 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Micro-Star product: GE75 Raider 8SE v: REV:1.0
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Micro-Star model: MS-17E2 v: REV:1.0 serial: <superuser required>
    UEFI: American Megatrends v: E17E2IMS.11A date: 05/19/2020
  ID-1: BAT1 charge: 32.7 Wh (77.7%) condition: 42.1/53.4 Wh (78.7%)
    volts: 11.5 min: 10.9 model: MSI BIF0_9 type: Li-ion serial: N/A status: N/A
  Device-1: hidpp_battery_0 model: Logitech MX Vertical Advanced Ergonomic
    Mouse serial: <filter> charge: 55% (should be ignored) rechargeable: yes
    status: discharging
  RAM: total: 31.19 GiB used: 3.8 GiB (12.2%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges
  Info: model: Intel Core i7-8750H bits: 64 type: MT MCP arch: Coffee Lake
    gen: core 8 level: v3 built: 2018 process: Intel 14nm family: 6
    model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xF0
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
    L3: 9 MiB desc: 1x9 MiB
  Speed (MHz): avg: 952 high: 1367 min/max: 800/4100 scaling:
    driver: intel_pstate governor: powersave cores: 1: 970 2: 800 3: 800 4: 800
    5: 1273 6: 802 7: 1108 8: 922 9: 800 10: 1367 11: 987 12: 800
    bogomips: 52815
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush
    clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64
    dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu
    fsgsbase fxsr ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ida
    intel_pt invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor
    movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm
    pdpe1gb pebs pge pln pni popcnt pse pse36 pts rdrand rdseed rdtscp
    rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp
    syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi
    vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: vulnerable
  Type: mds status: Vulnerable; SMT vulnerable
  Type: meltdown status: Vulnerable
  Type: mmio_stale_data status: Vulnerable
  Type: retbleed status: Vulnerable
  Type: spec_store_bypass status: Vulnerable
  Type: spectre_v1 status: Vulnerable: __user pointer sanitization and
    usercopy barriers only; no swapgs barriers
  Type: spectre_v2 status: Vulnerable, IBPB: disabled, STIBP: disabled,
    PBRSB-eIBRS: Not affected
  Type: srbds status: Vulnerable
  Type: tsx_async_abort status: Not affected
  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Micro-Star MSI
    driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
    ports: active: eDP-1 empty: DP-1,HDMI-A-1 bus-ID: 00:02.0
    chip-ID: 8086:3e9b class-ID: 0300
  Device-2: NVIDIA TU106M [GeForce RTX 2060 Mobile] vendor: Micro-Star MSI
    driver: nvidia v: 515.65.01 alternate: nouveau,nvidia_drm non-free: 515.xx+
    status: current (as of 2022-08) arch: Turing code: TUxxx
    process: TSMC 12nm built: 2018-22 pcie: gen: 2 speed: 5 GT/s lanes: 16
    link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.0 chip-ID: 10de:1f11
    class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
    compositor: kwin_x11 driver: X: loaded: modesetting,nvidia gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 75 s-size: 652x366mm (25.67x14.41")
    s-diag: 748mm (29.44")
  Monitor-1: eDP-1 mapped: eDP-1-1 model: AU Optronics 0x409d built: 2018
    res: 1920x1080 hz: 144 dpi: 128 gamma: 1.2 size: 382x215mm (15.04x8.46")
    diag: 438mm (17.3") ratio: 16:9 modes: 1920x1080
  OpenGL: renderer: NVIDIA GeForce RTX 2060/PCIe/SSE2 v: 4.6.0 NVIDIA
    515.65.01 direct render: Yes
  Device-1: Intel Cannon Lake PCH cAVS vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl
    bus-ID: 00:1f.3 chip-ID: 8086:a348 class-ID: 0403
  Device-2: NVIDIA TU106 High Definition Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:10f9 class-ID: 0403
  Sound Server-1: ALSA v: k5.18.17-1-MANJARO running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.56 running: yes
  Device-1: Intel Cannon Lake PCH CNVi WiFi vendor: Rivet Networks Killer
    Wireless-AC 1550i Wireless driver: iwlwifi v: kernel bus-ID: 00:14.3
    chip-ID: 8086:a370 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Qualcomm Atheros Killer E2500 Gigabit Ethernet
    vendor: Micro-Star MSI driver: alx v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: 3000 bus-ID: 05:00.0 chip-ID: 1969:e0b1 class-ID: 0200
  IF: enp5s0 state: down mac: <filter>
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 2.07 TiB used: 1.83 TiB (88.3%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston
    model: RBUSNS8154P3256GJ size: 238.47 GiB block-size: physical: 512 B
    logical: 512 B speed: 15.8 Gb/s lanes: 2 type: SSD serial: <filter>
    rev: E8FK11.C temp: 42.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WDS100T2B0B-00YS70 size: 931.51 GiB block-size: physical: 512 B
    logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 00WD
    scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 vendor: KingSpec model: ACSC4M1TS25
    size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 4H scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 113.18 GiB size: 110.84 GiB (97.94%) used: 76.35 GiB
    (68.9%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2 label: root
    uuid: f87ef1fe-5eec-4ec5-b98c-105742ac8e6d
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 1.8 MiB
    (0.6%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 label: EFI
    uuid: 2FA5-9041
  ID-3: /run/media/rabcor/86069E6C069E5D4D raw-size: 124.98 GiB size: 124.98
    GiB (100.00%) used: 55.12 GiB (44.1%) fs: ntfs dev: /dev/nvme0n1p4
    maj-min: 259:4 label: N/A uuid: 86069E6C069E5D4D
  ID-4: /run/media/rabcor/KingSpec raw-size: 953.87 GiB size: 953.4 GiB
    (99.95%) used: 944.91 GiB (99.1%) fs: xfs dev: /dev/sdb1 maj-min: 8:17
    label: N/A uuid: 7081018e-cce8-4d7d-b093-bb681ff46b8e
  ID-5: /run/media/rabcor/WD raw-size: 931.51 GiB size: 931.51 GiB (100.00%)
    used: 798.66 GiB (85.7%) fs: f2fs dev: /dev/sda1 maj-min: 8:1
    label: Western Digital uuid: ae81d12d-6838-4833-b47b-8dd120364382
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: file size: 512 MiB used: 0 KiB (0.0%) priority: -2
    file: /swapfile
  ID-1: /dev/nvme0n1p3 maj-min: 259:3 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 16 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-2:2 info: Logitech Unifying Receiver type: Keyboard,Mouse,HID
    driver: logitech-djreceiver,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s
    power: 98mA chip-ID: 046d:c52b class-ID: 0300
  Device-2: 1-7:3 info: Realtek RTS5129 Card Reader Controller
    type: <vendor specific> driver: rtsx_usb,rtsx_usb_ms,rtsx_usb_sdmmc
    interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 0bda:0129
    class-ID: ff00 serial: <filter>
  Device-3: 1-9:4 info: SteelSeries ApS KLC type: HID
    driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s
    power: 300mA chip-ID: 1038:1122 class-ID: 0300
  Hub-2: 2-0:1 info: Super-speed hub ports: 8 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 49.0 C pch: 52.0 C mobo: N/A gpu: nvidia
    temp: 51 C
  Fan Speeds (RPM): N/A
  Processes: 339 Uptime: 10m wakeups: 3 Init: systemd v: 251
  default: graphical tool: systemctl Compilers: gcc: 12.1.1 alt: 11
  clang: 14.0.6 Packages: pm: pacman pkgs: 1614 libs: 496 tools: pamac,yay
  pm: flatpak pkgs: 0 Shell: Bash v: 5.1.16 running-in: konsole inxi: 3.3.21

Update: I was able to use sudo nvidia-smi -lgc 300,645 to limit the clock speed the same way powermizer would at level 0, however -lmc is not supported so I can’t limit the memory speed (and it likes to really ramp up at every opportunity so al ot of power gets lost to that still)

Instead of using the nvidia gpu all the time and locking it to low clocks, doesn’t offload mode and runtime pm work?

There’s a couple of reasons but one of the key ones is that offloading causes problems which aren’t present when i’m just always using the nvidia gpu (for instance sometimes the system will hard freeze/crash when I run a game without vsync which is very bad, sometimes mpv freezes when using vulkan renderer and swapchain depth is greater than one (there’s a git issue for this on mpv’s end)

Ultimately though, what I want is to get the most performance I can for the least amount of power, and I wanted to see if there’s a sweetspot where using the nidia gpu would net me more performance for less power than just using the igpu would.

It’s kind of a moot point now though, even if someone proposes a solution I can’t test it because trying to force my way around the issue I tried flashing to a few different VBIOSes, until I landed on one that bricked my card.

I get

Nvflash CPU side error Code:2Error Message: Falcon In HALT or STOP state, abort uCode command issuing process.

whenever I try to reflash it with the original vbios, and nothing I’ve tried has been able to fix it :')

I originally flashed it with nvflash from windows, and i’m getting this error from nvflash on linux. I thought (although it’s a stretch, a long shot) maybe if I could run nvflash from windows again I could get around the issue, however I cannot boot into windows, it boots to a black screen, only reason I can boot into linux is because uninstalling the drivers was sufficient there, and easily done from a chroot.

Meanwhile on the windows side of things I can’t find a way to uninstall the nvidia drivers since the only way I’ve found to do so requires booting ino windows, and I can’t boot into windows.

Does reflashing the full system bios fix that?
Booting Windows: safe mode doesn’t work either? You could try creating a Windows PE usb boot drive.

I tried reflashing the bios it didn’t help, also tried booting windows into safe mode (e.g. I booted it and let it crash af ew times until that blue screen where you can boot into safe mode comes up (since starting with windows 8 i think, or maybe 10, u can’t just press F8 to get into safe mode anymore)) but i didn’t get further than that, I just got a blank blue screen.

Windows PE isn’t a bad idea, I suppose I could also just set up windows 7 or something since those don’t come with drivers pre-installed. I’m gonna try that, but ultimately it’s still a long shot I don’t hold out much hope for it working.

Did you try flashing an image you could previously flash?

Yeah, i always get that same error

Woot! The Windows PE idea worked! (Thanks for that!) My gpu is working again, weird that it wouldn’t work from linux though. Anyhow, returning to the original subject, is there any way I can force power mizer to the lowest level?

OverrideMaxPerf has been silently dropped somewhen but the powermizer setings used to work but on some systems fail. If -lmc doesn’t work, I don’t know of any other means to achieve this.