nvidia-smi reports setting application clock not supported for GTX 1070 (Ubuntu 16.04, drivers 375.26 & 378.09)

I have 2x Asus Dual GTX 1070 GPUs (DUAL-GTX1070-O8G) running on Ubuntu 16.04. I am unable to manually set clocks or target fan speed. I have Cuda 8.0 toolkit installed and have tried changing settings using both 375.26 stable and 378.09 beta drivers.

Running:

nvidia-smi -q -d SUPPORTED_CLOCKS

returns N/A

Likewise setting clocks is “not supported”:

> nvidia-smi -i 0 -ac 4004,1987

Setting applications clocks is not supported for GPU 0000:01:00.0.
Treating as warning and moving on.
All done.

Similarly I get issues trying to change settings using nvidia-settings, for example:

nvidia-settings -a "[gpu:0]/GPUMemoryTransferRateOffset[0]=100"

runs but stdout is empty

Likewise

nvidia-settings -a "[gpu:0]/GPUGraphicsClockOffset[0]=100"

also runs without producing any output.

I have also tried booting into Windows 10 running driver 378.49 and I have the same issues. nvidia-smi reports “Setting applications clocks is not supported for GPU”.

All other reports I have found of this issue say that it’s a driver issue, but updating to the suggested drivers has not resolved the issue for me. Is there anything I can do to manually set the clocks?

Asus provides a tweaking application for windows. Is it possible for the GPU to be locked by the vendor?

Any help would be greatly appreciated!

For the sake of process-of-elimination:

  1. Are your cards’ BIOS / firmwares up-to-date (if not, I would update one and test it individually for comparison before updating the other)?

Version 1.02 GTX1070updatebios 2016/12/26 update

DUAL-GTX1070-O8G | Graphics Cards | ASUS USA
https://www.asus.com/us/Graphics-Cards/DUAL-GTX1070-O8G/HelpDesk_Download/

  1. Have you tested nvidia-smi on each of the cards individually in each of the two PCIe x16 slots you are presumably using (the presence of both cards may be confusing nvidia-smi)?

  2. Have you tried swapping the cards’ slot locations?

  3. Have you tried installing the secondary card into a *PCIe x8 slot so that the motherboard has an even better chance of detecting that card as being distinctly different from the other?

  4. If your motherboard supports PCIe Gen3, Gen2 and Gen1 slot speeds on its PCIe x16 slots, have you tried changing the speed to PCIe Gen2 (doing so is unlikely to undercut the performance of a GTX 1070)?

*September 8, 2016
Titan X Performance: PCI-E 3.0 x8 vs x16 - Puget Custom Computers
https://www.pugetsystems.com/labs/articles/Titan-X-Performance-PCI-E-3-0-x8-vs-x16-851/

BTW. Posting complete and accurate system specs. in your forum signature (model numbers are good) would be more than helpful in aid of a trouble-shooting attempt as having them handy would eliminate time-consuming guess-work. (You may have to log out and then log back in to edit said signature.)

seems related to my bug report :
https://devtalk.nvidia.com/default/topic/992477/linux/bug-378-xx-nvml-nvidia-smi-core-clock-is-wrong-on-pascal-devices/

metaeaux, did you find a solution to this issue? I have exactly the same issue with EVGA GTX 1070 FTW cards.

Hello Guys,
I seek your help. If may I ask, I have a question.
How the hell did you get to run these beast under your control? I tried to tame the with driver, but I cant run them, only on X.Org X.

Would you help me to run my GTX1070 Windforce on any kind of linux?

thank you for all suggestions

I’m seeing the same thing with a 1060 GTX and 1070 GTX cards:

$ nvidia-smi -q -d SUPPORTED_CLOCKS

==============NVSMI LOG==============

Timestamp                           : Sat Sep 30 19:11:04 2017
Driver Version                      : 384.90

Attached GPUs                       : 3
GPU 00000000:03:00.0
    Supported Clocks                : N/A

GPU 00000000:04:00.0
    Supported Clocks                : N/A

GPU 00000000:05:00.0
    Supported Clocks                : N/A

Depending on the card ‘nvidia-settings’ fails in different ways. On a 1060:

$ sudo nvidia-settings -a [gpu:0]/GPUMemoryTransferRateOffset[3]=1200

nvidia-settings: libXNVCtrlAttributes/NvCtrlAttributesNvml.c:1709: NvCtrlNvmlGetValidAttributeValues: Assertion `ret2 == NvCtrlAttributeNotAvailable' failed.
Aborted

On a different 1060 or the 1070:

$ sudo nvidia-settings -a [gpu:1]/GPUMemoryTransferRateOffset[3]=1200

<no output>