Cant set clocks on my 3070 "Setting applications clocks is not supported"


I got my RTX 3070 (giabyte gaming oc 8gb) gpu for my home server. For heating the room and minging purposes. I have no X installed on my server. I can set power limit with nvidia-smi but when I try to set clocks I get “Setting applications clocks is not supported”

I have read internet and I have to add some “coolbits” (do I understand correct) ? but as I have no X, no xorg.conf … how can I add these coolbits ? How can I enable setting clocks for my card ?

Or even how can I force it into pstate 0 ? I cant use nvidia-settings because I have no X.

Please help :) feeling bit cheated without ability to set clocks :) … there must be a solution ? something ? no matter how difficult :)

I installed Xming on my desktop computer hoping that I can open nvidia-settings by directing DISPLAY to my desktop but now I get error “ERROR: Unable to load info from any available system”

there must be a way to do it :) please somebody direct me right way :)

when I start PhoenixMiner I get message “Unable to load NVML” … somehow I think(I am speculating purely :D) NVML is the thing that deals with clock and everything … do I need install something extra to get NVML ? or do I need to load some module ? remove “#” in some config file ?

still help help :) I see quiet a lot of topic on that same issue but I havent found a solution that works for me (no X is probably the cause) … lets get bottom of it I guess it would make many people happy :D well being of the world :)

okay I managed to get my clocks as I want them :)

but I had to install X and then do it in nvidia-settings, PhoenixMiner still cant load NVML but well, whatever :) doesnt matter really :)

nvidia-smi still tells me that “Setting applications clocks is not supported” …

people in nvidia, do you plan do some command line application to change clocks ? or it always have to be that clumsy way through X and nvidia-settings ?

alse I noticed that nvidia-settings did not have way to set power limit … is it normal that you set these things in 2 separated places ?

sorry I been team red player for quiet some time … my last nvidia was GTX 295 :) or was it 290, cant remember but it was long time ago I had nvidia card :)

Setting application clocks is a feature mostly reserved for Quadros and Teslas, very few R/GTX cards support that.
compute stuff is set using nvidia-smi
gaming stuff like overclocking is set in nvidia-settings
You’re doing compute tasks on a consumer card and want to set gaming features.
You might try using
sudo nvidia-smi -i 0 --lock-gpu-clocks=,
which has a better chance to work on consumer gpus.


Im okay, I got it working just it is clumsy way to do it … why cant there be one app that does it all ? yes gaming and computing is bit different but again to separate them is like you have two shovels in your garden, one for carrots and one for potatoes … they both look the same and work the same just they got different function … it is bit stupid I think but well :) I got it working … yes it is clumsy and do not score high points for nvidia but still it is working

sudo nvidia-smi -i 0 --lock-gpu-clocks= - set clocks for gpu, I am actually downclocking my gpu to overclock my memory more … I feel like it is so for some stupid (corporate) reasons …

anyway I have seen quiet a few threads with same problem, I just hope that reading my monologue here they can find something to solve their problem (like do not try to go around the problem but install X and use nvidia-settings and be done with it)

How did you overclock with nvidia-settings? which command did you do?