is it still possible to underclock (oveclock) the GPU under linux?

I’ve been trying the past few days to under clock my GPU (to test whether my kernel is bandwidth limited or compute limited). I remember that there used to be an option inside nvidia-settings to do it, but it’s missing now and I can’t seem to get it back.

Enabling coolbits doesn’t seem to do a thing.

Trying to change the clocks from the command line also doesn’t see to have any affect. nvclock is in the same place (doesn’t even get correct readings), nvidia smi also doesn’t seem to get the correct readings.

The machine is running debian unstable with kernel 3, tried driver versions 280 and 285 (earlier ones don’t install on this kernel). Tried on several different machines, but this particular desktop is running a GTX450 and a Tesla C1060.

Will be happy for any pointers.


I don’t think clock control is possible anymore with the Fermi GPUs. Not sure what’s up with the C1060 though. (Did that ever work with nvclock?)

Last year I investigated this for making an auto-stability testing script in Linux.

Overclocking in Linux is annoying. You can do it through nvidia-settings GUI or command line. But it’s only functional if the watchdog timer is on for the GPU in question. This usually means it has to have a display hooked up to it.

I surmise this is so display GPUs can be boosted for OpenGL, etc.

Caveat: I haven’t tried in the past year with more modern drivers… maybe things have changed.

is that true if you have persistence mode enabled (or nvidia-smi looping in the background)?

I used to have this option enabled in nvidia-settings, but I don’t see it now. It was on a machine with compute 1.1 device though so I don’t know if it’s driver version, Fermi or X version.

Trying to connect remotely to the machines with the Tesla to run nvidia-setting fails with a complaint that there are no connected devices, same problem on my laptop with optimus (intel + Quadro 2000m), Cuda can use the GPU, OpenGL can’t and nvidia-settings won’t see it. Looks like there is at least an issue with having a display connected, but it doesn’t seem enough as running on a GTX480 locally and a GTX450 + Tesla C1060 produce the same result (nvidia-settings comes up, but no clock section).

Looks like it boils down to either a driver version, Fermi or X. I don’t have a machine with an older card at the moment. Can try to download a live CD and see if installing the driver on that works and gives overclocking options.

It’s a pity as it’s a pretty handy tool to quickly analyze if your kernel is compute and/or memory bound, and to get away with pushing a GeForce into a server environment, to drop the cards, temperature.