[381.xx] [BUG] nvidia-settings incorrectly reports GPU clock speed

Something like 12-18MHz(375.10)/49-54MHz(375.20), while nvidia-smi correctly reports 177MHz which is the lowest for this card: GTX 1060 6GB.

Please, fix.

375.20 - the frequency has changed but it’s still 100% incorrect.

375.26 - no changes.


This hasn’t been fixed in 381.09 :-(

@Aaron, please fix this bug.

1080 on 381.09 :

nvidia-smi -q 
        Graphics                    : 55 MHz
        SM                          : 55 MHz
        Memory                      : 4513 MHz

Same issue ? same weird value (since 378.xx)

Yeah, looks like the same issue.

nvidia-smi -q

==============NVSMI LOG==============

Driver Version                      : 381.09
        Graphics                    : 8 MHz
        SM                          : 8 MHz
        Memory                      : 810 MHz
        Video                       : 100 MHz

This bug is still not fixed for the graphical nvidia-settings utility.

Under NVIDIA 381.22 I still get 56-66MHz for Graphics Clock.

Meanwhile nvidia-smi -q reports the proper clocks.



use nvidia-settings -t -q GPUCurrentClockFreqs

i dont have this problem here

I don’t understand your comment. I’m perfectly aware that in CLI the reported clocks are correct. This doesn’t invalidate this bug report or the necessity to fix it.

I want it to be fixed that’s why I’m bumping it.

We are working on it for fix.