nvidia-settings not showing correct performance level info / clock speed for 660Ti?

I changed from a 460 GTX to a Gainward GeForce GTX660 Ti Phantom yesterday. Had already installed the latest 310.19 and recognized that nvidia-settings is showing wrong clock speed in performance level 3 for that card. It should be 1006 MHz for graphics but it is 705 as in Performance Level 2.

As said, i had that driver already installed before with the 460 GTX, and it showed correct values for all levels for the old card.

So my question: is this just cosmetics / a displaying problem in nvidia-settings and my card is running with 1006 MHz, or is it really just running with 705 MHz in level3?

Any way to verify that? I tried nvidia-smi -q as root but showed N/A most rows, and also in:

Clocks
    Graphics                : N/A
    SM                      : N/A
    Memory                  : N/A

Opensuse 11.4, 32 Bit, 310.19 driver, Gainward GeForce GTX660 Ti Phantom

confirm the same issue !
p.s> nvidia please update the instructions how to configure xorg.conf

same issue here, gainward 660 ti phantom ( i didn’t even realize till seeing the first post, but i can confirm i’ve always had 705mhz with all 300 drivers. i’m on 310.19).

also note the PCIe link speed. mine changes from 2,5 to 5 gt/s

The 2,5 GT/s is correct in all - i just have a PCIe of first Generation, so it is the maximum.

Btw - did anyone find a suitable test or Info if the card is really running with only 705 MHz?

As I said, nvidia-smi -q mostly shows only N/A, seems like the latest drivers 3xx.xx for the 660Ti has still some functionality missing.
So to verify: can anyone run nvidia-smi -q and look if there is also N/A’s?

yes yes i have the same output from nvidia-smi -q, lots of N/As

nvidia-smi has been cripple on purpuse by nVidia a while back, be happy it shows this much information too.

@rusty1: what part of xorg.conf config are you missing?

@Al777: use a Windows machine to test the card and post a picture from GPU-Z

Ok here we go, under winXP all seems ok

my question is just still if the driver under Linux doesnt run the card in full clock …

Hi Al777,

We currently have a known clock reporting issue for Kepler products on Linux; it should only affect the clock values reported through the driver, but the GPU will actually be running at full clocks. Sorry for this, we’re aware of the issue and tracking it.

Thanks,

  • Pierre-Loup

Thank you for clarifying this! Good to know it runs at full potential and its just a reporting issue.

I have just double checked this and beside that, if there are different issues, opened my own topic on https://devtalk.nvidia.com/default/topic/527882/linux/clock-speeds-linux-gtx-660/

I mainly use the GPU for rendering. I have a benchmark scene which finalizes the render in Windows after 1:21 and in Linux after 2:05 minutes. So it is not just a matter of showing the wrong clock speed. Could you please double check this?

Thanks and best regards
Martin

I have tried the Unigine Heaven benchmark for win xp and my opensuse 11.4, with same settings so far i can judge. Result was:

OpenSuse 11.4 / 313.18 /1920x1080 OpenGL: 63,4 fps/ 1598
WinXP 306.81 driver /1920x1080: 58,4 fps/ 1472

So its almost equal (slight advantage for linux but winxp driver is not the latest one)

But Yes, I also have had a bad guts feeling if it was really only a “cosmetic” issue, but seems to be only this.

@Roaster: any handy benchmark i can use without much hassle to install is welcome, if you like to do me another test.

That would be great. Are you familiar with Blender? You can use Cycles for rendering with GPU and download the benchmark scene at Link

I installed Blender on my Linux machine and my Windows machine. Standard installs. Since Blender uses pure CUDA kernel power, it is a great baseline to compare.

I also installed nouveau driver, but it does not work yet. But at least nouveau shows me the correct clock speeds. So it must be a problem with the driver.

Ok will install blender and run the benchmark scene but may take one or two days i have less time currently…