Gainward Geforce GTX 770 Phantom 2GB half clock speed.

Ok I posted about this in the Geforce forums first before I realized there was a dedicated one for Linux.

So I bought a Gainward GeForce GTX 770 Phantom 2GB
I have installed the 319.23 drivers from xorg-edgers PPA
I run Linux Mint 15 64bit
have a Core i7 LGA 2011
32GB of DDR3 1600MHz RAM

And NVIDIA Settings tell me that the card runs at 540MHz GPU and 3.5GHz memory at max (3) preformance level.
This is the same clock speeds that are given for preformace level 2.
Witch makes me think it is a bug in the driver?
The card is factory overclocked and should run at 1150MHz on the GPU and 7GHz on the memory.

If there is any other information I can give that will help solve this, please let me know.

I have the same problem with a GTX 770M MXM Card in my XMG P503 laptop.

gpu clock speed stays the same for all of the 3 performance level (405 MHz), where the memory clock is increasing. Also the OpenGL and CUDA performance is very poor tested with Serious Sam 3, Oil rush and bfgminer (hash rate only 20% higher than a 640M LE card).

EDIT: System Information
319.23 nvidia-drivers
13.3 xorg-server
3.10-rc5 Linux
Gentoo Linux
i7-4700MQ
16GB DDR3 1600MHz RAM

I will add the nvidia-bug-report.log.gz file later that day, because I don’t have access to my laptop now.
nvidia-bug-report.log.gz (61.1 KB)

some additions to my problem:

this is the performance level table

Pl  Graphics Clock  Memory Clock
0   405             405
1   405             810
2   405             2004

I’ve noticed, that I am never reaching 2 and my gpu stays at 56°C temperature though I am playing some games on highest possible settings without lags.

I “can” only play Serious Sam 3 with Graphics set to Medium.

So you have a diffrent card so I assume it must be a bug in the driver then.
Hope they come with an update soon :)

By the way, your card seems to be a GK104 Chipset and mine a GK106. So it has something to do with the driver. But I’ve tested a bit with nouveau today and guess what:

[  718.136964] nouveau W[     DRM] voltage table 0x50 unknown
[  718.136987] nouveau  [     DRM] 3 available performance level(s)
[  718.137000] nouveau  [     DRM] 0: core 202MHz shader 405MHz memory 405MHz voltage 100mV
[  718.137008] nouveau  [     DRM] 1: core 405MHz shader 810MHz memory 1080MHz voltage 80mV
[  718.137015] nouveau  [     DRM] 3: core 1002MHz shader 2004MHz memory 1080MHz voltage 40mV

nouveau is the open source driver so would make sense for the same bug not to be in that one.
Yeah the 770 Desktop is GK104 same as 680 with higher memory clock.
the 770M is based on the older GK106 same chip as in 660 desktop I beleave.

It would be nive if somebody from nvidia would say anything about that.

I mean I spent some money on a new laptop to have decent gpu/CUDA power (I had a GT 630M before and witht he same OS installation I hadn’t the problem there).

IT would be enough to hear something like “yeah, the release next week will fix that”.

This isn’t just a “little displaying error”, but a big performance issue so I see this issue as a blocker. I don’t like to pay much money for a laptop with a fast gpu, to have only performance compared to a GT 640M card even if it is only on Linux.

GPU/RAM frequencies reported by nvidia-settings are halved. Your GPU runs at full speed in Linux.

Hopefully this visual glitch will be fixed in new drivers.

no, it doesn’t. I don’t get much more performance compared to a GT 640M like I said. I have to play Serious Sam 3 nearly on the same settings (graphic set to medium, high is very laggy). OpenCL performance in bfgminer is only about 25 MH/s. A GT 640M is getting about 21 MH/s, my old GT 630M 16 MH/s.

I am damn sure, that a GTX 770M should get about 100 MH/s in bfgminer, also should play Serious Sam 3 on high or even ultra settings without problems.

It could be, that this only a visual problem in nvidia-settings, but the low performance is also there.

We are internally tracking this issue under Bug 1154553 .

thanks for taking care of this issue :)

With the nvidia-driver 319.32 the issue is still there, but the PowerMizer table is much more detail, so I will give an update on my issue:

the gpu core clock is pending between 135 MHz (idle) and 405 MHz. This is the range of the Performance Level 0.
Though nvidia-settings is telling me, that the card is switching to level 1 (135MHz - 862MHz) the clock is still capped at 405 MHz.

Setting the Preferred Mode to “Prefer Maximum Performance” will result in this as well as running gpu heavy stuff.

Any update on this bug ? I’m delaying the aquisition of the Gainward GeForce GTX 770 Phantom 2GB.

319.32 fixes the showing wrong GPU Clock speed for my card.
The RAM clock still shows as 3505MHz instead of 7GHz
But I think thats intentional.

I have still the same situation as with 319.23
319.32 was much better, but this detailed table is gone now in 325.08

Ok thanks, I’ll order this card and will report here if I encounter any problem with it.

I confirm this issue:
Gentoo 64 / Kernel 3.9.8
Nvidia Drivers 325.08 and 319.32.

The GPU clock speed can’t go further than 540Mhz whereas memory speed seems to scale well with performance level.
From the performance level 1 to 3, the GPU clock speed remains the same.
I don’t get more performance than my Geforce 560ti!
Is there any workaround available ?

The only one I know is using windows for GL performance hungry applications. With an integrated intel gpu you could try to use VT-d and use the gpu in a virtual machine with native drivers. But these “workarounds” aren’t good at all.

I’m having this issue as well on Inno3D 770 4GB iChill HerculeZ
Core clocks at max 540 MHz and idle at 405 MHz.
With 326.19 even the memory clock was locked at idle.
With 320.49 the memory clock works fine, but core clock is still stuck at 540 MHz.

Hi guys!
Is someone still reading this thread? :)
I have Phantom 4GB with same problem. And maybe I’ve found solution.
Read this:
https://forums.geforce.com/default/topic/551701/geforce-700-600-series/gtx-770-underperforming-even-on-low-gfx-/post/4026117/#4026117

Same thing goes for 2GB version.