nvidia-settings graphics clock report

In powermizer tab the graphics clock dont match with performance level 1. Prefer maximum performance mode enabled. Stuck at 1071 Mhz and in unigine benchmark stuck at 1215 Mhz. Never reach the full 1346 Mhz.

driver 370.28
kubuntu 16.04

Hi Yokochi,

What graphics card do you exactly have? What are it’s specified normal and boost clocks (if it has a boost clock setting)?

On my GTX970 (EVGA 04G-P4-3975-KR) powermizer reports with default settings the maximum possible overclock on the card at the “Max” column (for both graphics clock and memory transfer rate). However, with offset=0 (no overclock) the card will be capped at the boost clock for my card - and, actually does reach the values intended by the manufacturer (actually, the said cards graphics clock goes momentarily 50mHz over the boost clock specified by the manufacturer, but the behaviour is exactly same in Windows on this card).

So the “Max” column is actually over your card spec, at least for higher performance level. At performance level 1, which is the second lowest performance level, it should never go up to your cards maximum. I believe (though I’m not sure - and I’m guessing it might depend on your graphics cards BIOS) perf level 2 = stock rated normal speed and performance level 3 = boost speed (it the card has one configured at the factory - not all cards have a “stock overclock”).

EDIT: For example, here’s a link to my card specs (they are same at EVGA site). At least on this card the actually reached clocks are in line with the specs (but “Max” column is maximum possible overclock, and never actually used!). this gtx750tioc lists normal clock as 1072 and boost clock as 1150. You might have a slightly different card, but it seems certainly possible you are already reaching the rated speeds.

My card is an ASUS NVIDIA GTX750TI OC 90YV05J0-MONACO.

Powermizer Information
Adaptive clock:Enabled
Graphics clock:1071Mhz
Memory transfer rate:5400Mhz
Power source:AC
Current PCIe link width:16x
Current PCIe link speed:5,0GT/s
Performance level 1

Powermizer levels
Level 0 - Graphics clock - min=135Mhz max=405Mhz Memory transfer rate - min=810 max=810
Level 1 - Graphics clock - min=135Mhz max=1346Mhz Memory transfer rate - min=5400 max=5400

Powermizer settings
Prefered mode:Prefer maximum performance
Current mode:Prefer maximum performance

And btw in previous versions of the driver the clock stuck in Graphics clock at max of the level 1, this is 1346Mhz, all the time. Should i have, in the Powermizer levels, another level (level3 i mean)?

Thank you very much for reply.

Hi again,

Been away for a while.

However, from the looks of it, I wouldn’t worry too much about your clocks. If you want to be sure, try the card on a Windows machine (if possible) and compare the results from Windows side to that reported in Linux.

I don’t have that many NVidia cards, and while the one I have reports four performace levels (0-3), this might depend on the card (manufacturer/model) and BIOS. Altough you only have two, that might be the cards design (BIOS). I really can’t shed any more light on this, but perhaps someone else might chime in =)


Thank you for reply.

I dont use windows, so i can’t test on it. One thing i know on kubuntu 14.04 the Graphics Clocks was all the time 1346Mhz and dont throttling like it does now. The card in idle the clock is 1071Mhz, under load is 1215Mhz, so the gpu boost is not working.


You may override the nvidia settings on X startup, by adding a small script in /etc/X11/xinit.d (and making it executable). Here is mine, for a KFA2 GTX 970 EXOC:


if lsmod | grep nvidia &>/dev/null ; then
	nvidia-settings -a SyncToVBlank=0
	nvidia-settings -a "GPUPowerMizerMode=1"

exit 0

It disables sync to V-blank and locks powermizer in the “Performances” mode.

You may also overclock the card by adding more lines in the “if” clause, e.g.:

nvidia-settings -a "GPUGraphicsClockOffset[level]=delta1"
	nvidia-settings -a "GPUMemoryTransferRateOffset[level]=delta2"

where “level” is the max powermizer level for the card (since we locked it in Performances mode; for my own card, level=3) “delta1” and “delta2” are clock delta values, in MHz, compared to the stock GPU clock rate/Memory transfer rate of the card.

Also, do not forget to add:

Option         "Coolbits" "12"

to the “Device” section of your /etc/X11/xorg.conf file, else you won’t be able to override powermizer default settings.

Protip: You can do that with one invocation of nvidia-settings and two -a arguments, to avoid having to load nvidia-settings twice.


Thank you all for helping me.

But the above solutions and overclocks have been tryed by me with strange results.
Is it normal for a card with extra 6pin power supply only draw 30w under heavy load?

During Unigine heaven benchmark:
0, 2016/11/01 00:33:41.627, 30.32 W, 1215 MHz, 2700 MHz, 1215 MHz

==============NVSMI LOG==============

Timestamp : Tue Nov 1 00:45:10 2016
Driver Version : 370.28

Attached GPUs : 1
GPU 0000:01:00.0
Power Readings
Power Management : Supported
Power Draw : 2.48 W
Power Limit : 38.50 W
Default Power Limit : 38.50 W
Enforced Power Limit : 38.50 W
Min Power Limit : 30.00 W
Max Power Limit : 38.50 W
Power Samples
Duration : 10.10 sec
Number of Samples : 119
Max : 3.32 W
Min : 2.20 W
Avg : 2.44 W