Xavier doesn't recognize PCIe card after installing Jetpack 5.0

Hi,

I would like to use a PCIe card with Jetson Xavier, but it doesn’t work properly.
Recently I upgraded to Jetpack 5.0 from Jetpack 4.6, and with Jetpack4.6, I can use it without any problem.
I can see the card in $lspci, but I cannot see any device in $lsusb.

PCIe card:

Error message:

$ dmesg
[ 1757.808870] xhci_hcd 0005:03:00.0: Abort failed to stop command ring: -110
[ 1757.809126] xhci_hcd 0005:03:00.0: xHCI host controller not responding, assume dead
[ 1757.809378] xhci_hcd 0005:03:00.0: HC died; cleaning up
[ 1757.809707] xhci_hcd 0005:03:00.0: WARNING: Host System Error
[ 1757.809870] xhci_hcd 0005:03:00.0: Couldn't Recover From Failure
[ 1757.810617] xhci_hcd 0005:03:00.0: Error while assigning device slot ID
[ 1757.811364] xhci_hcd 0005:03:00.0: Max number of devices this xHCI host supports is 32.
[ 1757.811678] usb usb4-port1: couldn't allocate usb_device

Any suggestion or advice is appreciated. Thank you!

Hi,

This is a PCIe card to jetson so lsusb shall not enumerate these devices, even though they seem like a usb device to those usb end devices.

Do you see them in the lsusb when you used jp4.6?

Thank you for your reply. I’m sorry I didn’t mention about the usb.
I should fix…
→ I cannot see any device in $lsusb when I put a USB device. (any device is OK, but in my case, Intel realsense or keyboard)

I could see these USB devices when I used JetPack4.6.

Hi,

Sorry that your question is kind of not clear. I am still not able to understand what you want to say here.

If your usb port is from a PCIe card, then it is a PCIe device to jetson. It shall not be listed on lsusb.

If you are talking about native usb port on jetson, then why do you post a PCIe card?

Thus, you better clarifying the situation.

Just in case you don’t understand what is “native usb port”. Native usb port means the default usb port we provided on the carrier board.

If your usb port is from a PCIe expander card, then it is not a native usb port.

Hi,
Thank you for your reply. I’m talking about USB ports from a PCIe card.

If your usb port is from a PCIe card, then it is a PCIe device to jetson. It shall not be listed on lsusb.

Then, I’m not sure how I can express this problem, but as the result, I cannot use any keyboard or USB devices plugged to PCIe card on Jetson Xavier AGX.
(I think I could see the USB devices (plugged to a PCIe card) in $lsusb when I used Jetpack4.6…though.)

It is also possible that the pcie card is calling some usb driver as a registered callback driver.

Please upload the dmesg for both your jp4.6.x and jp5.0 case. I mean the full log. Not only few lines.

I don’t have JetPack4.6 Xavier because I already upgraded to JetPack5.0. I will try to prepare JetPack 4.6 Xavier somehow. Please give me some time. It will take few weeks.

For JetPack5.0, I did
$ dmesg > log.txt
attached the file
log.txt (137.0 KB)

If you need something different, please just let me know.

Hi,
I prepared Jetpack4.6 Xavier and took the log of dmesg.
I used Intel realsense as the USB device on PCIe card.
log_jp46.txt (90.1 KB)

Thank you for your help in advance.

Hi,

Please provide full jp5.0 log. Your 5.0 log is incomplete.

Hi,
Thank you for checking the log. I uploaded the new log for JetPack5.0 below:
log_jp5.txt (92.7 KB)

Are you sure you don’t see anything in lsusb? From the dmesg, I can see usb devices from the pcie got enumerated.

Thank you for checking the logs. Yes, I confirmed again, but I cannot use any USB devices on PCIe card.

I’m sorry, I did misconfiguration one thing when I got the log_jp5.txt.
Could you update for the dmesg log for JetPack5.0?
dmesg_jp5.txt (95.4 KB)

Additionally, I got lsusb and lspci logs for both JetPack versions. I used Intel realsense for the USB device on PCIe card. (So I would like to see “Intel corp.” in lsusb.)
lspci_jp5.txt (1.2 KB)
lspci_jp46.txt (1.2 KB)
lsusb_jp5.txt (935 Bytes)
lsusb_jp46.txt (1.1 KB)