Xavier shows no hdmit output

I’m running an issue with my Jetson Xavier NX developer kit on a jetbot.

I have it connected with an ultrasonic sensor, a adafruit TB6612 ECS controller which then connected to 2 DC motors. I had 4 batteries powering up the motor and an adapter to power up the board. Everything works all good until yesterady I was when I plugged in the power source and access the board using VNC, nothing shows up. I then plugged in the hdmi cable to screen and the screens shows no signal.

I then unplugged all the connections and tried multiple times but the screen still shows no signal input.

Before that I did a soldering work that allows the battery to both power up the motor and the board, and when I plug in the power the board works all fine. I’m pretty sure that when I was doing soldering, the power was off.

I also tried to use another SD card with new os file and the board still won’t work. I tried to use SDKmanager to flash the system but it shows the board cannot be detected.

Any ideas to such situation? Did I accidently burn something on the board?


You have tried with other SD card, reflash the device…etc. Apparently, your board was damage by accendient as
I can only sugges to do the RMA, but not sure will be accepted, pleas try check the

What if I need an RMA (Return Material Authorization)?

If you believe that your Jetson product is defective, please contact the NVIDIA Customer Care team. We will help you troubleshoot your issue and process a replacement if it is found to be defective.

  1. Go to this link.
  2. Select “Live Chat” option to chat online with one of our customer care agents.
  3. Enter your contact information.
  4. Select the “Jetson” from the product drop-down list.
  5. Submit the request.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.