Yolov4 perf deepstream 6.0

Continuing the discussion from Deepstream 6 YOLO performance issue:

Please provide complete information as applicable to your setup.

**• Hardware Platform Jetson
**• DeepStream Version 6.0
**• JetPack Version 4.6
**• TensorRT Version 8.1
• NVIDIA GPU Driver Version (valid for GPU only)
**• Issue Type question

I have teh same issues as this post Deepstream 6 YOLO performance issue - #9 by adventuredaisy

Is this still an issue in the latest jetpack?

I have tried tried the suggestion above but face the below error when i rebuild the libnvdsinfer_custom_impl_Yolo.so

make: Entering directory ‘/opt/nvidia/deepstream/deepstream-6.0/sources/objectDetector_Yolo/nvdsinfer_custom_impl_Yolo’
g++ -c -o nvdsinfer_yolo_engine.o -Wall -std=c++11 -shared -fPIC -Wno-error=deprecated-declarations -I…/…/includes -I/usr/local/cuda-10.2/include nvdsinfer_yolo_engine.cpp
nvdsinfer_yolo_engine.cpp: In function ‘bool NvDsInferYoloCudaEngineGet(nvinfer1::IBuilder*, nvinfer1::IBuilderConfig*, const NvDsInferContextInitParams*, nvinfer1::DataType, nvinfer1::ICudaEngine*&)’:
nvdsinfer_yolo_engine.cpp:110:44: error: no matching function for call to ‘Yolo::createEngine(nvinfer1::IBuilder* const&)’
cudaEngine = yolo.createEngine (builder);
In file included from nvdsinfer_yolo_engine.cpp:26:0:
yolo.h:76:28: note: candidate: nvinfer1::ICudaEngine* Yolo::createEngine(nvinfer1::IBuilder*, nvinfer1::IBuilderConfig*)
nvinfer1::ICudaEngine *createEngine (
yolo.h:76:28: note: candidate expects 2 arguments, 1 provided
Makefile:51: recipe for target ‘nvdsinfer_yolo_engine.o’ failed
make: *** [nvdsinfer_yolo_engine.o] Error 1
make: Leaving directory ‘/opt/nvidia/deepstream/deepstream-6.0/sources/objectDetector_Yolo/nvdsinfer_custom_impl_Yolo’

Have you set your cuda version?

make -C nvdsinfer_custom_impl_Yolo

Thanks for your response. Yes I have set it.

Do you know if this is still needed with the latest version of jetpack 4.6 ver3

Could someone from Nvidia comment on this please?

yes, the instruction @adventuredaisy mentioned is needed for all DS version, including the latest release.


Do you know why I’m receiving the errors?

Have you tried the command with sudo?
$sudo make -C nvdsinfer_custom_impl_Yolo


$sudo chmod -R a+rwx /opt/nvidia/deepstream/deepstream-6.0/sources/objectDetector_Yolo/nvdsinfer_custom_impl_Yolo

then run
$make -C nvdsinfer_custom_impl_Yolo

Yes I also changed permissions with chmod 777 and no luck.

I’m going to do a fresh install on Monday. And start from zero. Fingers crossed.


After a clean install everything worked as explained in the original post. Thanks for your support.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.