3d world jittering

I tried out CloudXR together with Oculus Quest 2.
Framerate is at the cap and the rendering seems very smooth.
However, there is an effect, which gives a laggy feeling.
When moving my head close to a 3d model, the model has a jittering movement.
When I run the same application directly on the Quest 2, I cannot sense this effect.
Is this a known issue?
Any idea what causes this?

I can confirm I have the same problem. Jitter is particularly noticeable in translational movement. Rotation jitter is not noticeable because of asynchronous time warp. The problem happen on a every access point we’ve tested, using both Wi-Fi 5 and Wi-Fi 6 as well as on Focus 3 and Quest 1.

Moving the head around 3d model is pretty much the worst case scenario.

Virtual Desktop is performing much better in the jitter department.

Please help Nvidia.


I moved my CloudXR Server to a physical machine, which improved the performance a bit, and put HMD and server closer together.
In addition, I compared streaming to my pc with the HTC vive pro with streaming to android client of the Oculus Quest 2.
Both setups have one wifi hop in between.
In comparison, the pc version does not have the problem, or it is at least much less noticeable.
I tryed to capture a small video to show the problem.

You can see that, when moving from left to right the vertical edge of the cube is jittering and when moving from top to bottom the horizontal edge is jittering.

Oculus Quest 2:

HTC Vive Pro