64-32 bit Issue

I’ve installed cuda 64 bit (both sdk and toolkit) on my pc with visual studio 2005

I’ve got a Vista 64 bit, and a cpu intel dual core 32 bit (which emulate 64). I’ve compiled without problem the cutil project, but the template one give me follow error

[codebox]1>------ Build started: Project: template, Configuration: Debug Win32 ------


1>.\Debug\template.obj : fatal error LNK1112: module machine type ‘x64’ conflicts with target machine type ‘X86’

1>Build log was saved at “file://d:\Java\VisualStudio\CUDA\Debug\BuildLog.htm”

1>template - 1 error(s), 0 warning(s)

========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========[/codebox]

Any idea? I’ve tried also with both 32 bit version of sdk and toolkit but the error is the same…



In your VS project settings, under ‘Linker’ in the ‘Advanced’ section, there should be a ‘Target Machine’. What is that set to? Should be set for x64 if your target is a 64 bit exe.

HI, Thanks for replying. I’ve changed into x64 but error remains…

@edit: i’ve understood, i was running on x86 prompt. Now i have got

fatal error LNK1181: cannot open input file ‘cutil64D.lib’

on c++ ->include directories i’ve added the folder but nothing.
I’m sorry for these newbie question but i don’t understood VS05…

@edit#2 i’ve discovered the linked tab and now compile, but the exe doesn’t work because cutil64d is not included…

Probably not very helpful but: When I have similar issues, I usually just copy over all the settings 1-by-1 from a project that works. Even if you have extra includes, you can take those out later once you get it working.