About the RTC clock

Hi,
there is a VDD_RTC pin,and it was powered by PMIC, the external power just charge for it.So can I not connect this pin.And how to deal with it? Can it be unconnected?

VDD_RTC is connected to a SuperCap for RTC clock power, it is must for PMIC, and can not be unconnected.

Does it can be connected to a normal 3.3V power Or must a coin battery?

Must be a battery or SuperCap.

If I don’t need the RTC function, Can I not connect the VDD_RTC pin or don’t connect a battery or SuperCap

RTC backup battery is MUST.

Hi Trumany

what is the current consumption of the internal RTC circuit so that i can calculate the RTC backup and the capacitor size required .Is this information available in datasheet

It’s typical 2 uA

Trumany,

Are you saying RTC battery backup must be connected to a TX2 module even if a developer doesn’t need (or want) to use an RTC capability? What happens to a TX2 module if VDD_RTC is left unconnected?

Please refer to this topic (https://devtalk.nvidia.com/default/topic/1024890/jetson-tx2/tx2-carrier-board-hw-related-questions/) for latest update.

Hello

The current 2uA is the current that TX2 RTC pins Draws when is turned off?
I am trying to calculate the time for a super cap

where is this information in? I can not find that what document?

How can I calculate the time? I am suing this toolhttps://www.maximintegrated.com/en/design/tools/calculators/product-design/supercap.cfm

what is the vbatmax for tx2?

Thanks for pointing me to right place

The working current is 2uA, typical voltage level is 2.5V. You can calculate the time based on that and capacity of your super cap.

Hi ,

I have connected 0.2mF super cap Part Number: DSK-3R3H204T614-H2L to the VDD_RTC pin of the TX2 module.
Is there any command to enable the RTC in the TX2? If yes, Please let me know

Appreciate your efforts

Thanks
Vihang

The RTC is enabled in default.

Hi Trumany,

Thank you for the reply.

We are testing the Jetson TX2 RTC.

The time and the date in our TX2 module are getting updated through Wifi interface. But when we disable the Wifi interface and then switch off the system and again switch it on after few hours we do not see the time updated using RTC which we expect. We see the time data of the instance when we had switched off the TX2

Are there any settings need to be carried out in kernel files or other files to make the RTC work correctly. Please let me know.

Appreciate your support

Thanks
Vihang

0.2mF is not enough for hours work. The current is about 2uA in power off status, you can calculate the necessary cap accordingly.

Followed by #14

We have custom carrier board for Jetson TX2 module using with L4T 32.2.0. And we are getting Date & Time(RTC) update issue.

Below is two module data related to date and time :

1st JETSON-TX2 Data:

nvidia@tegra-ubuntu:~$ timedatectl
                      Local time: Fri 2020-02-28 12:19:42 IST
                  Universal time: Fri 2020-02-28 06:49:42 UTC
                        RTC time: Sat 2000-01-01 01:04:58
                       Time zone: Asia/Kolkata (IST, +0530)
       System clock synchronized: no
systemd-timesyncd.service active: yes
                 RTC in local TZ: no
				 
nvidia@tegra-ubuntu:~$ date
Fri Feb 28 12:19:43 IST 2020

2nd JETSON-TX2 Data:

nvidia@tegra-ubuntu:~$ timedatectl
                      Local time: Fri 2020-01-24 19:10:05 IST
                  Universal time: Fri 2020-01-24 13:40:05 UTC
                        RTC time: Sat 2000-01-01 01:01:58
                       Time zone: Asia/Kolkata (IST, +0530)
       System clock synchronized: no
systemd-timesyncd.service active: yes
                 RTC in local TZ: no
				 
nvidia@tegra-ubuntu:~$ date
Fri Jan 24 19:10:07 IST 2020

We don’t have any network connectivity in this carrier board, so not able to sync with network. Can you please tell why Date & Time is reset on each power up of carrier board, even if we have super cap in carrier board?

Is there any change require in kernel configuration?

How can we debug this issue?