Adafruit Servo Driver PCA9685 not working due to I2C Error

I have a Jetson Nano hooked up to the Servo Driver with power and I am attempting to run this code:

from __future__ import division
import time
import Adafruit_PCA9685

pwm = Adafruit_PCA9685.PCA9685()

But I am getting this error:

Traceback (most recent call last):
  File "Motor Test.py", line 5, in <module>
    pwm = Adafruit_PCA9685.PCA9685()
  File "/usr/local/lib/python3.6/dist-packages/Adafruit_PCA9685/PCA9685.py", line 74, in __init__
    self._device = i2c.get_i2c_device(address, **kwargs)
  File "/usr/local/lib/python3.6/dist-packages/Adafruit_GPIO/I2C.py", line 63, in get_i2c_device
    busnum = get_default_bus()
  File "/usr/local/lib/python3.6/dist-packages/Adafruit_GPIO/I2C.py", line 55, in get_default_bus
    raise RuntimeError('Could not determine default I2C bus for platform.')
RuntimeError: Could not determine default I2C bus for platform.

I ran this exact code and libraries on the raspberry pi and they worked with the exact same setup. I had to do sudo raspi-config for the raspberry to allow the use of I2C but I haven’t found an equivalent for the Jetson.

Please help :(

hello carlos.cuartas144,

this should be an issue that the i2c address is different with Adafruit.
had you modify the python code to update the i2c address? you may have a try to execute $ i2cdetect -y -r <i2c-bus-number>, and please assign correct i2c address to the script.