Jetson nano pca9685 error for servos

i wanna control 2 servos (sg90) for using fan/tilt to tracking face.

but i got some error.

$ i2cdetect -y -r 1, There was nothing wrong when I ran this code .


and i coded like that, with using adafruit, there is SyntaxError: future feature annotations is not defined

after then i upgrade to python3 3.7.9, it occur again

don’t know what to do…

Probably the same problem as this.

should i copy from "sudo pip3 install -U " to “Adafruit-SSD1306==1.6.2” and type on cmd?

i tried it but it doesn’t works again

Carefully look at the error log to find which package is causing the error.

i tries as “sudo”, it doesn’t works.
so i tried like this:
sudo -H pip3 install -U \ adafruit-circuitpython-busdevice==5.1.2 \ adafruit-circuitpython-motor==3.3.5 \ adafruit-circuitpython-pca9685==3.4.1 \ adafruit-circuitpython-register==1.9.8 \ adafruit-circuitpython-servokit==1.3.8 \ Adafruit-Blinka==6.11.1 \ Adafruit-GPIO==1.0.3 \ Adafruit-MotorHAT==1.4.0 \ Adafruit-PlatformDetect==3.19.6 \ Adafruit-PureIO==1.1.9 \ Adafruit-SSD1306==1.6.2
Requirement already up-to-date: adafruit-circuitpython-busdevice==5.1.2 in /usr/local/lib/python3.7/site-packages (5.1.2)
Requirement already up-to-date: adafruit-circuitpython-motor==3.3.5 in /usr/local/lib/python3.7/site-packages (3.3.5)
Requirement already up-to-date: adafruit-circuitpython-pca9685==3.4.1 in /usr/local/lib/python3.7/site-packages (3.4.1)
Requirement already up-to-date: adafruit-circuitpython-register==1.9.8 in /usr/local/lib/python3.7/site-packages (1.9.8)
Requirement already up-to-date: adafruit-circuitpython-servokit==1.3.8 in /usr/local/lib/python3.7/site-packages (1.3.8)
Requirement already up-to-date: Adafruit-Blinka==6.11.1 in /usr/local/lib/python3.7/site-packages (6.11.1)
Requirement already up-to-date: Adafruit-GPIO==1.0.3 in /usr/local/lib/python3.7/site-packages (1.0.3)
Requirement already up-to-date: Adafruit-MotorHAT==1.4.0 in /usr/local/lib/python3.7/site-packages (1.4.0)
Requirement already up-to-date: Adafruit-PlatformDetect==3.19.6 in /usr/local/lib/python3.7/site-packages (3.19.6)
Requirement already up-to-date: Adafruit-PureIO==1.1.9 in /usr/local/lib/python3.7/site-packages (1.1.9)
Requirement already up-to-date: Adafruit-SSD1306==1.6.2 in /usr/local/lib/python3.7/site-packages (1.6.2)
Requirement already satisfied, skipping upgrade: pyftdi>=0.40.0 in /usr/local/lib/python3.7/site-packages (from Adafruit-Blinka==6.11.1) (0.54.0)
Requirement already satisfied, skipping upgrade: Jetson.GPIO in /usr/local/lib/python3.7/site-packages (from Adafruit-Blinka==6.11.1) (2.0.18)
Requirement already satisfied, skipping upgrade: spidev in /usr/local/lib/python3.7/site-packages (from Adafruit-GPIO==1.0.3) (3.5)
Requirement already satisfied, skipping upgrade: pyusb!=1.2.0,>=1.0.0 in /usr/local/lib/python3.7/site-packages (from pyftdi>=0.40.0->Adafruit-Blinka==6.11.1) (1.2.1)
Requirement already satisfied, skipping upgrade: pyserial>=3.0 in /usr/local/lib/python3.7/site-packages (from pyftdi>=0.40.0->Adafruit-Blinka==6.11.1) (3.5)
WARNING: You are using pip version 20.1.1; however, version 22.1.2 is available.
You should consider upgrading via the ‘/usr/local/bin/python3.7 -m pip install --upgrade pip’ command.

does upgrading pip version is required?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.