Adding Cuda to Visual Studio C++ Project after project generation


before I started my current Cuda project, I checked, whether I could add Cuda support subsequently to an existing Visual Studio C++ project, which was basically just a right click on the project → build dependencies → build customizations → check the Cuda 11.7 box.

So, I tried this before and it just worked. I tried this today to merge the final project and it seems like that after some version updates of Visual Studio (tried it with VS 17.3 or older, now I’ve got 17.5.1 running) this somehow doesn’t work anymore, as doing so results in compile errors saying cuda_runtime.h and cuda.h could not be found.

What might cause this issue and how could it be fixed? Not sure, if “downgrading” might help, I mean… Microsoft…

Thank you

Well… if you do not restart Visual Studio after adding Cuda Toolkit via build customizations, it obviously doesn’t load the needed information -;.;-

… works now

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.