After installing CUDA toolkit i was deny log in access into Ubuntu 14.04

after install CUDA 7.5 toolkit and when I power on the server, I was deny log in though i’m pretty sure my password is correct and when I key in the password it did not say is incorrect, beside I did wrote the password down

The screen flashes for a min after I input the password and hit enter next it just stuck on the log in screen with the username.

What could be the cause? Could it be bugs and the Nvidia where CUDA install by itself during the update and installation. Though I did try using Ctrl+ALT+F1 and it allow me to go into a terminal though I did try the command of sudo and Xauthority next sudo reboot but still no go

I did a clean install of Ubuntu next download and install CUDA tool kit again. Once I shut down and power on again I would be prompt with the password log in page. Though I did input the correct password but it just wouldn’t allow me to log in

Pls help…

Holyshit I have to run sudo apt-get remove --purge nvidia-* to get rid of cuda tool kit and NVidia drivers then i’m able to log in again

Anyone can recommend a version of CUDA tool kit or Nvidia drivers that woudln’t deny user from logging into Ubuntu

It’s a login loop. If you search around on this board, you’ll find others who have run into it and possible solutions. Such as here:

https://devtalk.nvidia.com/default/topic/878117/-solved-titan-x-for-cuda-7-5-login-loop-error-ubuntu-14-04-/

[b]"Download your relevant CUDA.run file: mine was: cuda_7.0.28_linux.run
Note, that once again this install is if you purely want to use your graphics card (Titan X) for GPU/CUDA purposes and not for rendering.

Also run: $sudo apt-get install build-essential

  1. I start off with the regular GUI and Ubuntu working with no login problems.

  2. No need to create an xorg.conf file. If you have one, remove it (assuming you ahve a fresh OS install). $ sudo rm /etc/X11/xorg.conf

  3. Create the /etc/modprobe.d/blacklist-nouveau.conf file with :
    blacklist nouveau
    option nouveau modeset=0

Then $sudo update-initramfs -u

  1. Reboot computer. Nothing should have changed in loading up menu. You should be taken to the login screen. Once there type: Ctrl + Alt + F1, and login to your user.

  2. Go to the directory where you have the CUDA driver, and run
    $chmod a+x .

  3. Now, run $ sudo service lightdm stop
    The top line is a necessary step for installing the driver.

  4. I run the CUDA driver run file. *Notice that I explicitly don’t want the OpenGL flags to be installed:
    $ sudo bash cuda-7.0.28_linux.run --no-opengl-libs

  5. During the install:
    Accept EULA conditions
    Say YES to installing the NVIDIA driver
    SAY YES to installing CUDA Toolkit + Driver
    Say YES to installing CUDA Samples

Say NO rebuilding any Xserver configurations with Nvidia.

  1. Installation should be complete. Now check if device nodes are present:
    Check if /dev/nvidia* files exist. If they don’t, do :
    $ sudo modprobe nvidia

  2. Set Environment path variables:
    $ export PATH=/usr/local/cuda-7.0/bin:PATH export LD_LIBRARY_PATH=/usr/local/cuda-7.0/lib64:$LD_LIBRARY_PATH

*Change depending on your cuda version.

  1. Verify the driver version:
    $ cat /proc/driver/nvidia/version

  2. Check CUDA driver version:
    $ nvcc -V

[Optional] At this point you can switch the lightdm back on again by doing:
$ sudo service lightdm start.

You should be able to login to your session through the GUI without any problems or login-loops.

  1. Create CUDA Samples. Go to your NVIDIA_CUDA-7.5_Samples folder and type $make.

  2. Go to NVIDIA_CUDA-7.5_Samples/bin/x86_64/linux/release/ for the demos, and do the two standard checks:
    ./deviceQuery
    to see your graphics card specs and
    ./bandwidthTest
    to check if its operating correctly.

Both tests should ultimately output a ‘PASS’ in your terminal.

  1. Reboot. Everything should be ok"[/b]

Looking at the above guide. Just a thought if I were to reinstall Cuda toolkit, could I continue to run wget http://developer.download.nvidia.com/compute/cuda/7.5xxxxxx to download Cuda toolkit or I should download CUDA and next install it manually?

"Create the /etc/modprobe.d/blacklist-nouveau.conf file with :
blacklist nouveau
option nouveau modeset=0

Then $sudo update-initramfs -u"

How do i create the /etc/modprobe.d/blacklist-nouveau.conf file?

Do i simply open a terminal and next type blacklist nouveau?

Follow by option nouveau modeset=0?

Refer to the documentation:

http://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html#runfile-nouveau

As root, open a text editor. Type the stated contents in. Save the file as the indicated name in the indicated location.

The text editor, could i use gedit to type the stated contents in and next save the file? Was told by someone to use VIM text editor but can’t seems to locate VIM text editor in Ubuntu 14.04