Unable to login to Ubuntu 14.04 Desktop after installing cuda Toolkit 8 [.deb (network)]

Hi All,

I am having GTX-1050ti attached to Dell PowerEdge T420 server having ubuntu 14.04 (x86_64)

I am trying to install Cuda Toolkit -8 .deb(network) – https://developer.nvidia.com/cuda-80-ga2-download-archive

Installation Instructions:

`sudo dpkg -i cuda-repo-ubuntu1404_8.0.61-1_amd64.deb`
`sudo apt-get update`
`sudo apt-get install cuda`

Pre-installation and Post-Installation steps followed as mentioned in Installation guide

nvidia-smi is also working properly

But after reboot, I am not able to login to Ubuntu Desktop.

Also when I uninstall cuda, I am able to login again.

Please help to restore login to ubuntu with cuda installation.

Thanks and Regards,
Saloni

Are there other display adapters in the T420 besides that 1050Ti (including any non-NVIDIA display adapters?)

Yes it is having Matrox Graphics, Ltd. G200eR2

lspci | grep -i --color ‘vga|3d|2d’
06:00.0 VGA compatible controller: Matrox Electronics Systems Ltd. G200eR2
41:00.0 VGA compatible controller: NVIDIA Corporation Device 1c82 (rev a1)

You’ll need to follow the instructions in the linux install guide to avoid disrupting the matrox display stack.

http://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html#runfile-advanced

note the option:

No OpenGL Libraries --no-opengl-libs Prevents the driver installation from installing NVIDIA’s GL libraries. Useful for systems where the display is driven by a non-NVIDIA GPU. In such systems, NVIDIA’s GL libraries could prevent X from loading properly.

This option necessitates a runfile install methodology, not deb.

Please read and fully familiarize yourself with the linux install guide.

Thanks for the reply.

Followed the following steps:

Install NVIDIA Accelerated Graphics Driver for Linux-x86_64 367.48?
(y)es/(n)o/(q)uit: y

Do you want to install the OpenGL libraries?
(y)es/(n)o/(q)uit [ default is yes ]: n

Do you want to run nvidia-xconfig?
This will update the system X configuration file so that the NVIDIA X driver
is used. The pre-existing X configuration file will be backed up.
This option should not be used on systems that require a custom
X configuration, such as systems with multiple GPU vendors.
(y)es/(n)o/(q)uit [ default is no ]: n

Install the CUDA 8.0 Toolkit?
(y)es/(n)o/(q)uit: y

Enter Toolkit Location
[ default is /usr/local/cuda-8.0 ]:

Do you want to install a symbolic link at /usr/local/cuda?
(y)es/(n)o/(q)uit:
Do you want to install a symbolic link at /usr/local/cuda?
(y)es/(n)o/(q)uit: y

Install the CUDA 8.0 Samples?
(y)es/(n)o/(q)uit: n

Installing the NVIDIA display driver…
Installing the CUDA Toolkit in /usr/local/cuda-8.0 …

===========
= Summary =

Driver: Installed
Toolkit: Installed in /usr/local/cuda-8.0

Samples: Not Selected


After reboot able to login in ubuntu dektop

But Device Node Verification failed – No device /dev/nvidia*

Running the script mentioned in http://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html#runfile-verifications
gives the error:
modprobe: ERROR: could not insert ‘nvidia’: No such device

Am I missing something??

perhaps you did not remove nouveau - I don’t see it in the list of things you did - covered in the install guide in runfile install section
perhaps you have a previous package manager install that you did not clean out properly - covered in the install guide under “handle conflicting installation”

You may want to start over with a clean load of the OS.

as an aside, you appear to be using CUDA 8 GA1 based on the driver offered (367.48). I would recommend using CUDA 8 GA2, but you should certainly still be able to make CUDA 8 GA1 work if that is what you want to use.