AGX Xavier doesn't recognize UFS sd card

I flashed my AGX Xavier to Jetpack 5.0 a few days ago. And added a nvme SSD card for storage.
However, my UFS sd card cannot be recognized now. It works fine before.
I cannot see it under /dev or use GParted.
log.txt (137.3 KB)
The log of dmesg is attached here.
Another thing is that I saw this in the log and don’t understand what happened.

Can someone help?


update: I rebooted the machine and attached another dmesg log
log-2.txt (78.5 KB)

  1. Is this the nv devkit or some custom board? And you use the sd slot for your UFS card?

  2. If you flash back to jp4, then it would work?

Hi Wayne,
Yes, it is the NV devkit and I am using the sd slot for the UFS card.
Unfortunately, I cannot roll back to Jetpack4 anymore as my host machine is Ubuntu20.04 which only supports Jatpack5.0. The previous jetpack was flashed by another student who already left our group.
The UFS card works fine before for the same board.
Another thing to mention is that I forgot to take the UFS out when I flash the board. Does it matter?


Does not matter.

Then would the AGX Xavier supports nvme SSD and UFS at the same time?
The only 2 changes I can think of are:

  1. Add a nvme card
  2. upgrade to Jetpack 5.0
    And can you find any clue in the dmesg log?

Could you go to this node and share me the result?

nvidia@nvidia:/proc/device-tree/ufshci@2450000$ cat status

It shows ‘disabled’

Looks like we find the reason. Will check.

Hi Wayne,
Hope you are doing well!
Do you know how to turn on this?


Could you directly enable that ufs node in the device tree and try?

Sure. May I know which file and how to modify it to enable the UFS?

Hi Wayne,
Just want to follow up on this as I don’t know how to enable the ufs node even after searching around.
Could you help provide some specific steps that I can do?



Do you have the experience of building device tree, replace old one and flash it?

Because the issue here is just one line change, so I think the issue here feel like you don’t modify device tree before?

To be honest, I don’t have any experience related to the device trees. May I know what specific steps I should do?


There are multiple ways to do that. The simplest way here is to check /boot/extlinux/extlinux.conf and see which dtb file is in use.

Go to that path, use dtc tool to de-compile the dtb binary back to dts source. Open that source, go to the ufs controller, set the status from “disabled” to “okay”, then compile the dts back to dtb. Replace the old file.

And then reboot.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.