Jetson xavier nx ssd boot (sda)


I have trouble using xavier nx.
I want to change root from sdcard reader to 256G SSD(/dev/sda1).
Now I can boot on sdcard reader using SDKManager. (by picking storage emmc)
Pictures are my disks information.
Help me…

Hi jjj,

Are you using the devkit or custom board for Xavier NX?
What’s your Jetpack version in use?

Could you share the result of the lsblk on your board?

Thanks for answering.
Maybe I don’t use custom board. This is link I bought.
And… My product is ‘Boxer-8253AI-JP46E-A1-1111’.

This is result of the ‘lsblk’. I just refreshed on EMMC. Jetpack version is 5.1.1.

I tried GitHub - jetsonhacks/rootOnNVMe: Switch the rootfs to a NVMe SSD on the Jetson Xavier NX and Jetson AGX Xavier but it doesn’t change root path after booting.
And I tried ‘echo {my product PartUUID} > > l4t-rootfs-uuid.txt_ext’. Then ‘sudo ./ jetson-xavier-nx-devkit-emmc sda1’
When reboot the xavier, error show on my screen.
[ERROR] couldn’t open directory lib/modules/5.10.104-tegra: No such file or directory
[FATAL] could’t search modules: No such file or directory

Sorry for the late response, have you managed to get issue resolved or still need the support? Thanks

This is the custom carrier board…

Do you get the custom BSP package from your vendor?
You should use flash command to flash into SD card and select boot from SD card in UEFI menu.

I contacted the buyer and solved it. Thanks.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.