Boot from USB on Jetson Xavier NX

Hi,
We are using the Jetson Xavier NX carrier board (Model No: 900-83668-0000-000 and eMMC - 16GB). We are able to flash the images using SDK manager Jetpack 4.4. We are trying to flash the images from USB but we dint get much information. Is there any option to boot the images from USB? If yes kindly share with us the instruction guide/ Steps to flash the images from USB.

Note: We do not have an SD card slot on the Jetson Xavier carrier board.

Hi,

Please note that we only provide the method to boot the “rootfs” from usb drive. It means part to boot component is still on emmc.

https://elinux.org/Jetson/L4T/Boot_From_External_Device

We are following https://elinux.org/Jetson/L4T/Boot_From_External_Device for booting from USB on Jetson Xavier Nx. When we give following command sudo tar -cpf - * | ( cd /mnt/ ; sudo tar -xpf - ) facing lot of issues like
usb_boot_error_log.txt (403.8 KB) . Please try to help on this.

Hi,

Are you able to put any file to your usb drive?

Also, this step is on host. Are you running this on host?

Yes. We can able put any file to usb drive and it is running on host only.

Using https://elinux.org/Jetson/L4T/Boot_From_External_Device for booting from USB on Jetson Xavier Nx. Till now upto copying rootfs to sdcard
is done.After that how/ where to execute this sudo ./flash jetson-tx2 external command.

Have you ever tried sdkmanager on your host machine?

Yes we have tried using sdk manager flashed jetpack 4.4 on jetson-tx2. Now we have to do booting from USB on Jetson Xavier Nx and following link has been used https://elinux.org/Jetson/L4T/Boot_From_External_Device in which first 4 steps have been completed. For executing 5th step sudo ./flash jetson-tx2 external following query we have:

  1. Where to connect usb drive whether in host machine or board.
  2. Where to execute the 5th command.

Hi,

SDKM downloads and installs Linux_for_Tegra on your host. SDKM also uses flash.sh to flash you board.
Thus, please search your host for this folder.

  1. Where to connect usb drive whether in host machine or board.

I am not very sure about this question. When you are preparing the rootfs, you need to connect the usb drive on host. During flash, you need to connect it to tegra device.

We tried the same, while flashing facing following issues Error: Return value 8
Command tegrarcm_v2 --download bct_bootrom br_bct_BR.bct --download bct_mb1 mb1_bct_MB1_sigheader.bct.encrypt --download bct_mem mem_rcm_sigheader.bct.encrypt
Failed flashing t186ref.

What is your command to do the flash?

sudo ./flash.sh jetson-xavier external.

Hi,

jeton-xavier is for the AGX Xavier module. If you are using NX, then you need to use

For sdcard module,
jetson-xavier-nx-devkit

For emmc module,
jetson-xavier-nx-devkit-emmc

Those *.conf files inside that folder define these parameters.

when we use sudo ./flash.sh jetson-xavier-nx-devkit external facing issue Erasing sdcard: 0 … 0000000074740311: E> NV3P_SERVER: Failed to open instance 0 of device 6.
[ 20.0939 ]
[ 20.0939 ] [Failed]
[ 20.0939 ]
Error: Return value 17
Command tegradevflash_v2 --pt flash.xml.bin --create
Failed flashing t186ref.
Note: We are using usb drive.
is this command correct?

Hi,

Why are you using jetson-xavier-nx-devkit? Didn’t you say you are using emmc module?

We are using the Jetson Xavier NX carrier board (Model No: 900-83668-0000-000 and eMMC - 16GB).

used jetson-xavier-nx-devkit-emmc and got the following logs:
[ 117.4969 ] Flashing completed

[ 117.4971 ] Coldbooting the device
[ 117.5003 ] tegrarcm_v2 --ismb2
[ 117.5200 ]
[ 117.5228 ] tegradevflash_v2 --reboot coldboot
[ 117.5266 ] Bootloader version 01.00.0000
[ 117.5447 ]
*** The target t186ref has been flashed successfully. ***
Make the target filesystem available to the device and reset the board to boot from external external.

After power on the device following logs could see :

Hi,

Please read below page and dump the log from uart.

https://elinux.org/Jetson/General_debug

Before you share your log, I suspect you didn’t format the external device correctly. Need to confirm this step.

Create GPT and partiton using gdisk on external device:

  $sudo gdisk /dev/sdx
  "o" -> clear all current partition data
  "n" -> create new partition
  "1" -> partition number /dev/sdx1
  "40M"first sectors -> Press enter or "+32G" last sectors
  "Linux filsystem" -> using default type
  "c" -> partition's name "PARTLABEL"
  "w" -> write to disk and exit. 

Also, what is the exact device you are using now? usb or sdcard?

We followed the above mentioned steps only and we are using usb only. please find the logs.xavier_nx_boot_logs.txt (27.6 KB) . Please let us know proceed further.

Hi,

Could you remove the “quiet” in Linux_for_Tegra/rootfs/boot/extlinux/extlinux.conf, reflash your board and dump the log again?