Jetson Linux and Jetpack OS Installation failed on Xavier NX Board

I am trying to install Jetpack on Xavier NX 16gb board but facing installment issue. Here is the log attached from SDK Manager terminal.

SDKM_logs_JetPack_5.1.1_(rev._1) (70.3 KB)

Here is the output from /media/fazliddin/rootfs/JetPack_5.1.1_Linux_JETSON_XAVIER_NX_TARGETS/Linux_for_Tegra/ --help

Usage: sudo ./ [options] <target_board> <rootdev>
	target board: Valid target board name.
	rootdev: Proper root device.
        -c <cfgfile> ---------- Flash partition table config file.
        -d <dtbfile> ---------- device tree file.
        -f <flashapp> --------- Path to flash application (
        -h -------------------- print this message.
        -i <enc rfs key file>-- key for disk encryption support.
        -k <partition id> ----- partition name or number specified in flash.cfg.
        -m <mts preboot> ------ MTS preboot such as mts_preboot_si.
        -n <nfs args> --------- Static nfs network assignments
                                <Client IP>:<Server IP>:<Gateway IP>:<Netmask>
        -o <odmdata> ---------- ODM data.
        -r -------------------- skip building and reuse existing system.img.
        -t <tegraboot> -------- tegraboot binary such as nvtboot.bin
        -u <PKC key file>------ PKC key used for odm fused board.
        -v <SBK key file>------ Secure Boot Key (SBK) key used for ODM fused board.
        -w <wb0boot> ---------- warm boot binary such as nvtbootwb0.bin
        -x <tegraid> ---------- Tegra CHIPID.
        -B <boardid> ---------- BoardId.
        -C <cmdline> ---------- Kernel commandline arguments.
                                Each option in this kernel commandline gets
                                higher preference over the values set by
                       In case of NFS booting, this script
                                adds NFS booting related arguments, if -i option
                                is omitted.
        -F <flasher> ---------- Flash server such as cboot.bin.
        -G <file name> -------- Read partition and save image to file.
        -I <initrd> ----------- initrd file. Null initrd is default.
        -K <kernel> ----------- Kernel image file such as zImage or Image.
        -L <bootloader> ------- Bootloader such as cboot.bin or u-boot-dtb.bin.
        -M <mts boot> --------- MTS boot file such as mts_si.
        -N <nfsroot> ---------- i.e. <my IP addr>:/my/exported/nfs/rootfs.
        -R <rootfs dir> ------- Sample rootfs directory.
        -S <size> ------------- Rootfs size in bytes. Valid only for internal
                                rootdev. KiB, MiB, GiB short hands are allowed,
                                for example, 1GiB means 1024 * 1024 * 1024 bytes.
        -Z -------------------- Print configurations and then exit.
        --no-flash ------------ perform all steps except physically flashing the board.
                                This will create a system.img.
        --external-device------ Generate flash images for external devices
        --sparseupdate--------- only flash partitions that have changed. Currently only support SPI flash memory
        --no-systemimg -------- Do not create or re-create system.img.
        --bup ----------------- Generate bootloader update payload(BUP).
        --single-image-bup <part name> Generate specified single image BUP, this must work with --bup.
        --bup-type <type> ----- Generate specific type bootloader update payload(BUP), such as bl or kernel.
        --multi-spec----------- Enable support for building multi-spec BUP.
        --clean-up------------- Clean up BUP buffer when multi-spec is enabled.
        --usb-instance <id> --- Specify the USB instance to connect to;
                                <id> = USB port path (e.g. 3-14).
        --no-root-check ------- Typical usage of this script require root permissions.
                                Pass this option to allow running the script as a
                                regular user, in which case only specific combinations
                                of command-line options will be functional.
        --user_key <key_file>   User provided key file (16-byte) to encrypt user images,
                                like kernel, kernel-dtb and initrd.
                                If user_key is specified, SBK key (-v) has to be specified.
                                For now, user_key file must contain all 0's.
        --uefi-keys <keys_conf> Specify UEFI keys configuration file.
        --rcm-boot ------------ Do RCM boot instead of physically flashing the board.
        --sign ---------------- Sign images and store them under "bootloader/signed"
                                directory. The board will not be physically flashed.
        --image --------------- Specify the image to be written into board.
        --boot-chain-flash <c>  Flash only a specific boot chain (ex. "A, "B", "all").
                                Defaults to "all", inputs are case insensitive.
                                Not suitable for production.
        --boot-chain-select <c> Specify booting chain (ex. "A" or "B") after the board is flashed.
                                Defaults to "A", inputs are case insensitive.
        --pv-crt -------------- The certificate for the key that is used to sign cpu_bootloader

Here is the output from running the commends:
grep media /etc/mtab

/dev/sda1 /media/fazliddin/Extreme\040Pro exfat rw,nosuid,nodev,relatime,uid=1000,gid=1000,fmask=0022,dmask=0022,iocharset=utf8,namecase=0,errors=remount-ro 0 0
/dev/sdb1 /media/fazliddin/boot fuseblk rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096 0 0
/dev/sdb2 /media/fazliddin/rootfs fuseblk rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096 0 0

df -H -T /media/fazliddin/rootfs/JetPack_5.1.1_Linux_JETSON_XAVIER_NX_TARGETS/Linux_for_Tegra/rootfs/

Filesystem     Type     Size  Used Avail Use% Mounted on
/dev/sdb2      fuseblk   64G   12G   53G  18% /media/fazliddin/rootfs

The flash tool expected this /media/fazliddin/ to be a ext4 FS.

I have change the download folder location but not able to change the target hw image folder location in SDK Manager.
Here is the screenshot attached.

The screenshot already told the reason why it cannot change.

Sorry for asking so many dumb questions but i am not able to find any solution to this?
can you please

point me to the right direction.

The sdkmanager said your /dev/nvme0n1p7 does not have enough space.

And it indeed has no sufficient space.

I have solved the space issue but installation failed.

On jetson board there is not enough space left

I don’t think it is a jetson space issue yet… your flash even not started…

You skipped the flash. Are you trying to install sdk or you are trying to reflash OS? Or you don’t know what is the difference?

I have successfully flashed the OS once but Cuda and Jetson Inference components remained uninstalled so tried again and it shows me this error. On Jetson board I can see Cuda in /usr/local/cuda but mvcc -V results in error.

Please click the EXPORT LOG button on your sdkmanager and share the log.

Please see the attached log file.

SDKM_logs_JetPack_5.1.1_(rev._1) (273.2 KB)

What is the result of

sudo apt-get update
sudo apt-get install -y libtbb2 libtbb-dev
sudo apt-get install -y python-dev python-numpy python-py python-pytest"

running on your NX?

Also, what is df -h?

If disk space is really not sufficient, then you can only get external drive to use.

Here is the latest log file showing the error once i restarted the whole process from the beginning.
SDKM_logs_JetPack_5.1.1_(rev._1) (423.0 KB)

Attached image file shows the output from NX Board after running the commands you mentioned.

Also isn’t in SDK Manager Jetson Runtime Components and Jetson SDK Components same? So installing CUDA twice is causing the space issue on board?

Please help me in finding a solution to this issue:)

Please install sdk runtime only. No need to install sdk.

Sdk runtime is for small emmc device like Xavier NX to install. You need to reflash the board again and install sdk runtime only.

Thanks for your help, I successfully installed the runtime SDK on NX Board however, faced the CUDA and Opencv issue while loading through terminal.
Also the default python is 2.7.18.

Please be aware that we only reply one issue in a topic. Since original topic is resolved, please file new topic for this question.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.