AI fundamentals course difficulties

hey everyone,

I’m a newb and was trying to work my way through the NVIDIA AI fundamentals course when I hit two snags.

  1. I’m using a Pi v2 camera and when I ran the included script within the tutorial series it gave me this error:

"docker: Error response from daemon: error gathering device information while adding custom device “/dev/video0”: no such file or directory.
"
I read that if you delete "–device /dev/video0 " it would allow you to run the script. I went ahead and deleted the line and sure enough I was able to proceed. However, I’m now confused if my camera will even be recognized now? Will it not be recognized? Is there some other modification I need to make to this script to do that?

  1. Thoguh I was able to get that script to run and did get inside the container, when I clicked on the included jupyter notebooks link contained within the documentation the notebooks never load and the tab eventually times out. I’m completely stumped as to how to troubleshoot this. Any ideas?

Here’s the link to the course page with the code and jupyter link:
https://courses.nvidia.com/courses/course-v1:DLI+S-RX-02+V2/courseware/b2e02e999d9247eb8e33e893ca052206/63a4dee75f2e4624afbc33bce7811a9b/?activate_block_id=block-v1%3ADLI%2BS-RX-02%2BV2%2Btype%40sequential%2Bblock%4063a4dee75f2e4624afbc33bce7811a9b

Thanks :)

Hi @nbarrow85, when using a MIPI CSI camera (like the rPI v2 camera) within Docker container, you should launch the container with the following command-line option included:

-v /tmp/argus_socket:/tmp/argus_socket

However it is also good to test that you can view your camera outside of the container first. If you run nvgstcapture-1.0 from your Jetson (outside of container), you should see your camera’s video feed if you have a display attached to your Jetson.

Regarding the other issue that you mentioned, are you browsing JupyterLab from your PC? That is the recommended way to browse the JupyterLab notebooks, with the Jetson acting as the Jupyter server.

Hey,

Thanks for getting back to me. I’’ try adding that line into the script and see what develops.

So, yeah I was trying to browse jupyter from my pc while attempting to use my nano 2gb in headless mode as per the course instructions. If it’s useful info at all, the sd card that I flashed was from the “getting started with jetson nano 2gb” documentation-but that should have had jupyter pre-built, right?

The latest version of the course uses the standard SD-card image, and then provides JupyterLab pre-installed inside the container. This avoids needing a special image just for the course.

If you still have problems with browsing JupyterLab, let us know. There are logs that you can check inside the container (their locations are printed out when you start the container) that may contain additional information. Or I wonder if it is a wifi / networking connectivity issue with maintaining connection between your PC and Jetson?

What should I look for in the logs that might be fishy? As to the wifi connectivity-is there a way to verify that? I think it’s okay only because when I use the browser from the nano the connection has been fine. Also, ssh’ing into it works fine too. Is this verification enough? Pardon my newb-ness…

Any errors or warnings that it prints out once you try to load the notebooks. The easiest way to see messages that get triggered by you trying to load the notebooks, would probably be to run tail -f /var/log/jupyter.log from your docker terminal after you launch the container. This will watch the JupyterLab log for you, and if an error or timeout occurs when you try to open a notebook, you should see it pop up.

Note that the /var/log/jupyter.log being referred to resides inside the container. After you launch the container, you should be able to use the same terminal to check that file inside it. tail -f will follow it (watch it) for you and spit out any updates to the log to the terminal.

You could try pinging your Jetson device from your PC and keep an eye on it in the background (and see if the pings sometimes timeout, or if the latencies spike, ect). The ping command on Linux will keep pinging and run forever until you quit, while ping on Windows needs the -t flag command to keep running.

oh my god…

I’m a moron. Ugh. Just figured out the problem. I had been clicking on the provided link within the tutorial page itself without realizing that I should use my own IP address to open the notebooks (smacks head)

Thank you so much for all your help!! Password worked fine. Now im in!

Now I’ll test to see if my camera is operable…

Ah no worries, glad you got it started! I think the course documentation was written from the perspective that the Nano would be connected to the PC over microUSB (and hence would establish a virtual ethernet connection with a static IP of 192.168.1.55). Regardless, when the container starts, it should print out your Nano’s IP for you to connect to.

If you have trouble with the CSI camera, first I would hook up a monitor to your Jetson and make sure it can be viewed ok with the nvgstcapture-1.0 program (outside of the container).

Hey,

So I finally got jupyter;abs running and am inside the container going through the ‘hello camera’ documentation however I’m hitting some snags. I was able to verify that the CSI camera is working when I’m logged on to the nano locally but the command you included in your reply had some difficulty being incorporated into the rest of the script. I was able to get into the docker container with these commands:
'echo “sudo docker run --runtime nvidia -it --rm --network host
–volume ~/nvdli-data:/nvdli-nano/data
–volume /tmp/argus_socket:/tmp/argus_socket
nvcr.io/nvidia/dli/dli-nano-ai:v2.0.1-r32.4.4” > docker_dli_run.sh

I then made it executable and ran it. But now INSIDE jupyter I’m getting this error:
‘ls: cannot access ‘/dev/video*’: No such file or directory’

Should I access the container with different code?

Thanks!

Hi @nbarrow85, if you are using MIPI CSI camera, you can ignore that message about /dev/video*, because you don’t need those V4L2 devices to use MIPI CSI camera. Do make sure that you use the notebook for CSI camera though.

Thanks Dusty!