Any driver more recent than 352.63 locks me out of my consoles


I’m currently stuck with the outdated 352.63 Linux driver. Any version more recent than that will result in a blank screen when I try to switch to a console. When I switch back, the screen has pixel garbage in it.

dmesg says:

[    5.335834] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  361.42  Tue Mar 22 18:10:58 PDT 2016
[    6.102888] NVRM: Your system is not currently configured to drive a VGA console
[    6.102890] NVRM: on the primary VGA device. The NVIDIA Linux graphics driver
[    6.102891] NVRM: requires the use of a text-mode VGA console. Use of other console
[    6.102892] NVRM: drivers including, but not limited to, vesafb, may result in
[    6.102892] NVRM: corruption and stability problems, and is not supported.

But otherwise, with 352.63 and previous versions it always worked.

Also, I’d be more than happy to use a text-mode console, and I have tried more many hours to get one to work, only to later discover that it’s not possible because I have a UEFI system.

So there is literally nothing I can do.

I am using Gentoo Linux AMD64. My specs:

GPU: GTX 980Ti (EVGA ACX 2.0+ FTW)
CPU: Intel Core i5 2500K
Mainboard: MSI MS-P67A-C43 B3
Kernel: 4.4.6
X.Org: 1.18.2
Desktop: KDE 5 (Plasma 5.6.1)
nvidia-bug-report.log.gz (230 KB)

Please attach nvidia bug report.


I have the same problem. There are similar threads on the forums but all of them without an answer.

As for me, I have a good behaviour on the 355.xx drivers too but this driver doesn’t work with recent Linux kernels. All newer drivers have this bug.

Steps to reproduce:

  1. Boot in a working X11 screen, I use Xfce
  2. Switch to a terminal by pressing Ctrl+Alt+F1 for example
  3. Switch back by pressing Ctrl+Alt+F7

I have a black screen in the result. The computer seems to still receive some inputs but I don’t see anything. I run the debug script via a remote connection when I try to start a new X instance by entering command “startx – -logverbose 6

I can’t attach the nvidia-bug-report.log.gz because I have “Invalid access attempt” error

It was attached already. It’s in the first post :-/ Are you unable to see it for some reason?

Same for me after upgrade to Ubuntu 16.04 with NVIDIA driver 361.42 and graphics card GeForce GTX 970.

This also breaks the machine when trying to log out or switch users. This means I have to reboot to login as different user.

Login via SSH is extremely slow in this state and the poweroff and reboot commands return timeout errors after an additional while then.
All processes that are killed remain in state then.
Only the --force flag can reboot the machine.

Seems that the nvidia module blocks the complete kernel?