Can no longer run linux using Nvidia drivers

When I try to boot using nvidia drivers, the screen freezes, just before the login menu. I tried two operating systems ubuntu and manjaro, same problem. Manjaro live cd using nvidia drivers also doesn’t work.

For the ubuntu installation I was using xubuntu 20.04 with linux kernels 5.8 and 5.10, with nvidia drivers 440 460 and 465

For manjaro I tried kernels 5.8 5.10 5.12 and nvidia drivers 440 and 460. No luck

Manjaro xfce 21.0.5 live cd, using nvidia drivers also freezes.

I’m using a gtx 1660 super. Logs attached for the ubuntu installation. Problems with that installation started January 04 after noon.

Open-source drivers work without a problem.

nvidia-bug-report.log.gz (76.6 KB)

1 Like

Does it freeze dead or you can press Alt+Ctrl+F2 to enter console?

If it freezes before the login, maybe it’s the display manager? Since it’s Manjaro, I assume it’s LightDM. Maybe try to switch to GDM?

Side note. I also have problems with NVIDIA drivers. I started reading this forum and I am profoundly stunned by the amount of problems people are having. Times when NVIDIA produced quality drivers are long gone.

Alt+Ctrl+F2 doesn’t work. I didn’t try to change to GDM.

That being sai I found a solution. Both Xubuntu and manjaro work trough hdmi (I was using displayport).

For my monitor hdmi and displayport offer the same image quality , so changes to HDMI is an option. (because I have all may cable hidden, it will take some effort to reroute everything, but it is an option).

I will also try GDM, thanks for the help.

1 Like

GDM didn’t work. I will replace the displayport cable with an HDMI :(. Hope this helps others.

At least it works. I have Quadro, it has only DP outputs.

1 Like

Hope my post helps you. At least now we have reasons to believe the problem is related with displayport.

It is quite amazing how messy Nvidia drivers are. This is getting very hard to tolerate.

1 Like

They’ve been tossing out good engineers for several years, hiring friends and relatives.

1 Like

Yes that is an increasing problem everywhere.

But this is not a critic of anyone who works at Nvidia, I’m not even criticizing Nvidia per say. I’m just saying that when we look at the amount of people having problems with Nvidia drivers, and all the work arounds Linux automatically does when installing NVIDIA drivers , something is wrong.

It is hard to keep using NVIDIA drivers or graphics cards after this (i imagine changing to other card or drivers is not an option for you).

I don’t think it is useful to blame anyone who works at Nvidia or Nvidia itself. It might be helpful instead to move to other drivers or even graphics card. Or trying to understand why this happens. My guess is that Nvidia drivers being close source is the issue here, but I’m not an expert on drivers.

When Ubuntu/arch team detects a problem with the drivers , they can’t fix the drivers, instead they need to create an work around. This is messy and prone to more bugs.

Exactly in the same situation. The marked solution is unfortunately not possible for Quadro users. I can confirm that switching the display manager doesn’t change anything either. Ctrl+Alt+F# not working, so no terminal is accesible for running

Any info on whether there is any ongoing work to fix the DP-issue?

I guess, this must be pretty easy to reproduce:
-Quadro (P2200 in my case)+current Manjaro (out of the box)+autoinstall privative driver+reboot.

Great news! The blank-screen problem at login seems solved with release 470.42.01

For future reference, here is a working combination in my system:

  • Quadro P2200 (DP-only output)
  • Manjaro Linux 21.1.0 Pahvo
  • Linux Kernel 5.10.47
  • Nvidia driver 470.42.01

I’m having a similar issue, however the 470.42.01 driver does not fix the issue for me.
I’m running on Fedora 34, there are currently only 2 kernels in the repo for F34, 5.11.12 and 5.12.13

I have tried every driver version from 455 to 470 on both kernels, and the issue is always the same.
I can boot up an X server using the nouveau driver, or with no graphics driver at all, but cannot use the nvidia driver.
It hits a null pointer dereference error caused by nv_audio_dynamic_power everytime it tries to load any of the NV drivers.

Have tried with hdmi, dp and dvi connections (the gpu has 1 of each), with no luck, it even crashes when there is no monitor plugged in at all (verified via ssh on my phone to monitor logs).

I’m experiencing the same problem: NVIDIA driver hangs on boot.

Driver version is 465.31, system is Fedora 34, kernel 5.12.13-300.fc34.x86_64

The GPU is displayed as follows in lspci: 01:00.0 VGA compatible controller: NVIDIA Corporation GP106 [GeForce GTX 1060 6GB] (rev a1) (prog-if 00 [VGA controller])

Attaching nvidia-bug-report. It’s probably not extremely useful as I captured it on nouveau (system is completely unbootable with NVIDIA driver), but it still has details about my hardware and software.

A workaround that works is sticking to 390xx legacy driver.

If I remove “quiet” from kernel command line, it hangs on boot soon after the line “[drm] [nvidia-drm] [GPU ID 0x00000100] Loading driver”.

Switching to HDMI is not an option.

nvidia-bug-report.log.gz (109.0 KB)

Can confirm that 470.42.01 works for me on Fedora 34, kernel 5.12.13-300.fc34.x86_64.

Thanks @dolphguin for answer.

Had this problem with Fedora 36 trying out on Kernel 5.15.0-0.rc1.12.fc36.x86_64 rpm package from

Hacked through it by extracting the driver files with rpmdev-extract xorg-x11-drv-nvidia-390xx-kmodsrc-390.144-2.fc35.x86_64.rpm and tar -xf nvidia-390xx-kmod-390.144-x86_64.tar.xz

Ran make inside the folder with the Makefile in it, and edited files until the errors went away. Then re-created the archive with tar -cJf nvidia-390xx-kmod-390.144-x86_64.tar.xz kernel and put it back where it was.

And finally ran sudo akmods to rebuild the driver.

I hacked together a patch. But a better patch, that takes into account the kernel version, was already put together here.

Update: A newer version of the driver is available. And it should compile fine. But, as of now, it hasn’t been incorprated into the RPMFusion rpms yet…