anybody tried to compile opencl code on 64bit windows 7 with vs2008?

hello guys,

i have tried to compile the example programs on a 64bit windows 7. the code runs fine on 32bit vista, but i have a run-time problem on the windows7.

the binary executable examples are all runnable. but when i try to compile and execute the example project form visual studio, i have the following error:

run-time check failure #0 - the value of esp was not properly saved across a function call. this is usually a result of calling a function declared with one calling convention with a function pointer declared with a different calling convention.

is there anybody knowing how to fix this problem?


Are you using the 64bit SDK?

I have no trouble running or compiling OpenCL w/ Win7 64 and VS 2008

Even I’ve successfully run OpenCL 1.0 on Windows 7 64-bit with VS2008. Make sure you’ve installed the 64-bit drivers and SDK as previously mentioned. Also, make sure the environment variables are correct, I’ve found them to be faulty at times due to legacy installations.

Hey there,

Just wanted to let you know that I am running the same setup as you, and was running into the same problems.

My solution was to go get the 3.0 beta toolkit at

Took me a grand total of 3 minutes to install it - took 3-4 hours of fighting with it and eventually finding that page. Hopefully that works for you. Definitely some growing pains with OpenCL right now.

Make sure you’ve set the target to x64. The visual studio projects default to compiling for 32 bit. Simple yes, but it will have issues if this isn’t set.