Argus yuvJpeg sample missing pictures

Hi,

I noticed when I run the yuvJpeg sample, frames 2 and 3 are always missing. In other words I get “1.JPG”, “4.JPG”, “5.JPG”, etc. Why is this the case?

Thanks.

hello randyzhg,

would like to have more details from your side.

  1. what’s your environment setting, may i know which camera sensor you’re using.
  2. please share all the steps.
  3. please run the argus dae5mon manually to enable background messages.
sudo /usr/sbin/argus_daemon

I have the stock TX2 evaluation kit, so OV5693 I think.
Running ./jetsonclocks.sh before running the sample fixed the issue. I thought I already did that yesterday but I guess apparently not. Thanks.

hello randyzhg,

there’s timing issue in the yuvJpeg application, please set the stream to FIFO to fix the issue.
thanks

diff --git a/public/samples/yuvJpeg/main.cpp b/public/samples/yuvJpeg/main.cpp
index 7ed6d0e..ab649e8 100644
--- a/public/samples/yuvJpeg/main.cpp
+++ b/public/samples/yuvJpeg/main.cpp
@@ -228,6 +228,7 @@ static bool execute(const ExecuteOptions& options)
     {
         iStreamSettings->setPixelFormat(PIXEL_FMT_YCbCr_420_888);
         iStreamSettings->setResolution(STREAM_SIZE);
+        iStreamSettings->setMode(STREAM_MODE_FIFO);
         iStreamSettings->setMetadataEnable(true);

Ok thanks! I will try it.

I also have a general question. What are the advantages of using the Argus API over using nvcamerasrc with GStreamer?