Armbian for Jetson Nano

Test the alpha version of the Armbian for Jetson Nano. :)

The latest version of :

20.05 20200312

Start step. Download archive. Unpack. Write image to SD card (minimum SD card size from 8GB).

In these images we use a standard procedure of initial setting as in all the other images Armbian. The primary root password is 1234. :)

https://yadi.sk/d/W9SHvYXAIpFEew

Add content link for MEGA site.

https://mega.nz/#F!j9QSDQSQ!6WpasOlbZYIInfw6yo4phQ

Importantly. If image capture is used SD card which was previously recorded in any system for Jetson Nano. It is necessary to completely erase (zero) SD card. Details can be seen in these messages.

https://devtalk.nvidia.com/default/topic/1052684/jetson-nano/armbian-for-jetson-nano/post/5351568/#5351568

The order of initial setup can be seen here.

https://docs.armbian.com/

To output audio via HDMI, you need to switch to the desired option in the settings (by default, analog audio output is enabled).
By default, audio output via analog is enabled, to output audio via HDMI, you need to switch the default device to HDMI in the settings panel (in the upper right corner, click on the dynamics and select the first device in the list by default).

Details can be found on the Armbian forum.

https://forum.armbian.com/topic/9921-nvidia-jetson-nano/?do=findComment&comment=81135

Sorry for the dumb question, but what are the benefits of armbian over the ubuntu? not traying to start flame wars, just to understand…

nice work

Armbian is an “improved\extended” version of Ubuntu and Debian in 2 versions (Desktop and server). I have published one Ubuntu Desktop image so far. If there will be interest of users I can provide all 4 options of images for Nano. A small explanation of the purposes for which the optimal Armbian. Nano’s capabilities allow it to be used as a replacement for an ordinary PC. For example, as a replacement office PC for standard tasks (surfing the Internet, working with documents, etc.). In Armbian use advanced settings that improve the operation of the system, adding convenient tools for quick setup for specific tasks (utility armbian-config), etc. Reveal a little secret, how did Armbian for Nano. For a small company that is engaged in the development of robotics, it became profitable to update part of the working PC on the Jetson Nano. Several problems are solved at the same time. A single hardware component for infrastructure that can be used during non-working hours as a cluster to build work projects. A significant reduction in the cost of purchasing new conventional PCs with similar capabilities. Reduce energy costs. And a number of useful bonuses (increasing the number of purchased food reduces the price at a certain amount). :)

Congratulations on the port a armbian. With the current Ubuntu Jetpack distribution of nVidia, I’m having a lot of problems, any upgrade (a simple sudo apt-get update) breaks the distribution.

You have managed to run the demos correctly in armbian? I can’t wait to remove the T4L distribution from nvidia. See my post.

https://devtalk.nvidia.com/default/topic/1052809/jetson-nano/problem-with-the-2nd-boot-after-autoupdate-/

Aha. That isn’t what is breaking, and it’s possibly nvidia’s fault for their customizations and not Ubuntu to blame. The bug is only on first boot and a workaround is to boot without network. If it happens outside of that it’s likely a bad power supply or sd card .

I would recommend against installing an unknown image off the internet with a hardcoded root password and no first boot scripts as opposed to one built by Nvidia or canonical, no offense to op (I wouldn’t distribute my own images).

Bugs aside, they are likely to be fewer in L4T and you have nvidia’s software installed. If you want you can even fix the bug and build your own image with their tools.

@Glocke
Specify what “demos” are we talking about ?
Judging by the description from your link, you have a problem with the media (maybe the SD card itself or the card reader on Nano). I used a regular Ubuntu image for Nano and had no problem running the system and installing packages in it. I’ve tried several different SD cards for Ubuntu (with a recorded stock image for Jetson Nano) and several versions of Armbian, everything works without problems. Alternatively, you can try a combined system startup, bootloader on the SD card, and place the root on any USB flash drive for verification.

@mdegans
Maybe for You it is an unknown image (source). If You have doubts, I recommend to visit the forum Armbian and study the information there. For hundreds of Armbian and LibreELEC users, this source is almost “official”. :)

p.s. I do not impose anything on anyone, all adults themselves can decide how to act :)

Can we please get a debianized version without the UI and just ssh at boot ? get me off this terrible ubuntu os crap

1 Like

Has anyone tried this image ? Doesnt seem to even boot on my Nano…

If there are users who need Armbian (Debian) desktop images and a server, I can build them additionally.

Write down in detail what steps you are taking. I checked the image launch on my Nano, everything worked.

sudo systemctl enable ssh && sudo systemctl isolate multi-user.target

The screen will turn black, congratulations, you’re headless. Log in via ssh and if you like your nano this way you can:

sudo systemctl set-default multi-user.target

To make the change persistent.

10002* cd Downloads
10003* ls -al Armbian.zip
10004* mkdir ARM
10005* cd ARM
10006* unzip …/Armbian.zip
10007* xz -h
10008* xz -d Armbian/armbian_ubuntu_desktop_jetson_nano_20190527.img.xz
10009* ls
10010* cd Armbian
10011* ls -al
10012* sudo dd if=armbian_ubuntu_desktop_jetson_nano_20190527.img off=/dev/sde bs=1024k
10013* sudo dd if=armbian_ubuntu_desktop_jetson_nano_20190527.img of=/dev/sde bs=1024k
putsdcard in nano, plug in power
10014* ping 192.186.10.183

nothing, no boot no hdmi screen output no dhcp

What size of SD card ? Do you have the ability to connect a UART console ? On this map were data\partitions ? Try to /dev/zero the card and then record the image with a special program. On the forum Armbian there have been many reports (for different devices) on the startup issues when you use the utility DD to write the image files. Try to perform a GPT table recovery on the SD card after recording on the PC (after recording the image, the GPT table may not be activated correctly).

16Gb SDcard never had issues writing to sdcards via dd, both Nvidia Ubuntu and Yocto boot run fine on my board. ill see if I can get a console on it. I did also nuke via parted all partitions on the third try. ill try etcher next. Ive also never had issues with “Armbian” itself on other boards… this one just not happy. ill take a second look at it.

GPT:Primary header thinks Alt. header is not at the end of the disk.
[419019.787263] GPT:15564799 != 31116287
[419019.787263] GPT:Alternate GPT header not at the end of the disk.
[419019.787264] GPT:15564799 != 31116287
[419019.787264] GPT: Use GNU Parted to correct GPT errors.
[419019.787273] sde: sde1 sde2 sde3 sde4 sde5 sde6 sde7 sde8 sde9 sde10 sde11 sde12
[419032.564560] sd 4:0:0:1: [sde] 31116288 512-byte logical blocks: (15.9 GB/14.8 GiB)
[419032.973495] GPT:Primary header thinks Alt. header is not at the end of the disk.
[419032.973499] GPT:15564799 != 31116287
[419032.973501] GPT:Alternate GPT header not at the end of the disk.
[419032.973502] GPT:15564799 != 31116287
[419032.973503] GPT: Use GNU Parted to correct GPT errors.
[419032.973531] sde: sde1 sde2 sde3 sde4 sde5 sde6 sde7 sde8 sde9 sde10 sde11 sde12

sudo parted /dev/sde   16:31  14.06.19  56.75G RAM
GNU Parted 3.2
Using /dev/sde
Welcome to GNU Parted! Type ‘help’ to view a list of commands.
(parted) p
Warning: Not all of the space available to /dev/sde appears to be used, you can fix the GPT to use all of the space (an extra 15551488 blocks) or continue with the current setting?
Fix/Ignore? F
Model: TS-RDF8 SD Transcend (scsi)
Disk /dev/sde: 15.9GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
2 1049kB 1180kB 131kB TBC
3 2097kB 2556kB 459kB RP1
4 3146kB 3736kB 590kB EBT
5 4194kB 4260kB 65.5kB WB0
6 5243kB 5439kB 197kB BPF
7 6291kB 6881kB 590kB TOS
8 7340kB 7406kB 65.5kB EKS
9 8389kB 9044kB 655kB LNX
10 9437kB 9896kB 459kB DTB
11 10.5MB 10.6MB 131kB RP4
12 11.5MB 11.6MB 81.9kB BMP
1 12.6MB 7968MB 7956MB ext4 APP

(parted)

still not working

For analysis, to understand what the problem is, I’m waiting for a response from other users.

https://forum.armbian.com/topic/9921-nvidia-jetson-nano/?do=findComment&comment=80734

I gave the image a quick test drive there and it seemed to work fine.

armbian_ubuntu_desktop_jetson_nano_20190527.img -> Samsumg EVO Plus 32GB SD card using Win32DiskImager on Windows 10.

I didn’t do a lot of testing but booted up, played test video, checked network connections, apt-upgrade, reboot, installed GStreamer and ran the videotestsrc -> autovideosink.

All worked as expected. Looking forward to testing it in more depth when time allows. Great work so far

Thanks for the test. I already began to doubt the work of the image on other copies. :)

I believe you, but I need proof of life at this point, ive done everything, NVidia ubuntu works fine as does Yocto images, this one doesnt.

The UART console is necessary for the analysis.