ASUS FX505DT Ryzen7 - GeForce GTX1650 Mobile Debian Parrot

Hi,

I can’t send output signal to a HDMI external monitor.

Can anybody help me please.

Thanks in advance.

nvidia-bug-report.log.gz (222.5 KB)

You fiddled a bit too much at your config files.
Please create
/etc/X11/xorg.conf.d/01-nvidia-prime.conf

Section "OutputClass"
    Identifier "AMDgpu"
    MatchDriver "amdgpu"
    Driver "amdgpu"
EndSection

Section "OutputClass"
    Identifier "Nvidia-prime"
    MatchDriver "nvidia-drm"
    Driver "nvidia"
    Option "PrimaryGPU" "Yes"
EndSection

and set your display manager to run

xrandr --setprovideroutputsource 0 1 && xrandr --auto

https://wiki.archlinux.org/index.php/NVIDIA_Optimus#Display_Managers

Hi,

yes i try solve it for myself but whithout luck :-(.

For now i not have HDMI signal output.

nvidia-bug-report.log.gz (204.7 KB)

Thanks.

Ok, there’s a path entry missing so it can’t find the nvidia module. How did you install the driver?
BTW, which desktop environment/display manager are you using?

Hi,

Desktop is MATE and display managet LightDM.

I install drivers from Parrot repository “apt install nvidia-driver”.

Please change /etc/X11/xorg.conf.d/01-nvidia-prime.conf to:

Section "OutputClass"
    Identifier "AMDgpu"
    MatchDriver "amdgpu"
    Driver "amdgpu"
EndSection

Section "OutputClass"
    Identifier "Nvidia-prime"
    MatchDriver "nvidia-drm"
    Driver "nvidia"
    Option "PrimaryGPU" "Yes"
    Option "AllowEmptyInitialConfiguration" "true"
    ModulePath "/usr/lib/nvidia/current/"
EndSection

and remove the incorrectly modified system config files
/usr/share/X11/xorg.conf.d/10-amdgpu.conf
/usr/share/X11/xorg.conf.d/10-nvidia.conf
so they don’t interfere.

Hi,

Thanks.

I’ve modified /etc/X11/xorg.conf.d/01-nvidia-prime.conf , remove /usr/share/X11/xorg.conf.d/10-amdgpu.conf and
/usr/share/X11/xorg.conf.d/10-nvidia.conf and rebooted de system but still not have signal output on HDMI.

Any other config that can try?

nvidia-bug-report.log.gz (203.6 KB)

The X config is correct now. There’s one kernel module missing, it only loads
nvidia.ko
nvidia-modeset.ko
missing is
nvidia-drm.ko
Please check if it exist by running
modinfo nvidia-drm
and check if it’s blacklisted
grep “nvidia-drm” /etc/modprobe.d/* /lib/modprobe.d/*