Several Outputs missing in xrandr command and external monitor therefore doesnt work

i have a Rezer Blade 15 Laptop which is running the newest driver for it (Linux x64 Display Driver Version 430.50) as recommended by NVIDIA. Unfortunately i cant connect a external monitor and it seems like the computer doesnt know that i got:

  1. 1x Displayport, 1x HDMI, 1x USB-C with Thunderbold 3 and 3x USB-A ports.

GPU: GTX 1060 Max-Q Design
OS: Ubuntu 19.04
Monitor: LG 24MB67PY (works perfectly with other Devices)

Here is the Outout of xrandr:

eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)

As you can see there are beside the eDP-1 there are only two other ports.

Log report created with


nvidia-bug-report.log.gz (80.6 KB)

The nvidia driver is not loaded.
Please try this:

  • install nvidia-prime (sudo apt install nvidia-prime)
  • switch to nvidia (sudo prime-select nvidia)
  • remove stray blacklist files (sudo rm /lib/modprobe.d/blacklist-nvidia.conf /etc/modprobe.d/blacklist-nvidia.conf)
  • update the initrd (sudo update-initramfs -u)
  • reboot

Maybe i did something wrong but when i type in the 3rd command

sudo rm /lib/modprobe.d/blacklist-nvidia.conf /etc/modprobe.d/blacklist-nvidia.conf

the terminal responds this:

rm: cannot remove '/lib/modprobe.d/blacklist-nvidia.conf': No such file or directory
rm: cannot remove '/etc/modprobe.d/blacklist-nvidia.conf': No such file or directory

after this, i typed in the other commands correctly and rebootet my laptop but there where no changes. Should i attach a new nvidia-bug report maybe?

Thank you for you help :)

You have secure boot enabled, so the nvidia driver doesn’t load. Please disable secure boot in bios.

IT WORKS!!! Thank you a lot! In the past 7 days i read posts in aproximately 30 forums and tried everything but nothing worked for me. Again thanks a lot, this is very important for me.