at standstill with "Getting started with AI on Jetson Nano" course

Trying to install a Logitech C270 usb camera following instructions. Jupyterlab errors in usbcamera.ipynb with
"“Error creating widget: could not find model”

I can’t find a way to upload a screen shot or copy/paste the code but its in the notebook cell called “#Create a widget to view an image stream”. Nothing works beyond this point and I assume there is little point moving on with the course without a functional camera?

Hi peter.archer,

May I know which tab (notebbok) are you getting this error?
Also, are you running in device mode as suggested in the course?

Can you quickly try following steps:

  1. Close current notebook.
  2. Shutdown notebook by Kernel -> Shutdown Kernel
  3. In terminal $sudo systemctl restart nvargus-daemon
  4. Open notebook again and execute

Please let me know.

The notebook is usb_camera.pyidb

done all the steps you suggested multiple times without changing anything

I have tried going on further into the thumbs project. although there are no further errors, there is no video being displayed either.

The Logitech C270 does work OK. after booting back onto the jetson nano regular sd (not the dlinano version) with hdmi display and keyboard/mouse etc, I can use the camera from Cheese without problem. I even downloaded a python program from OpenCV for a usb camera and it worked fine (once I has installed numby)

I’ve ordered a RPI V2.1 camera, and I’ll give it a try when it gets here later next week. Still, it has to be made work with a usb camera, doesn’t it?

Thanks for responding so quickly, by the way :-)

.pyinb not .pyidb

For DLI course we suggest dli-nano sd image. Also, if you are connected on USB device mode (assuming here, Setup And First Boot worked).

Can you post output from, $jupyter labextension list
I will compare with my dlinano image which is working and let you know.

The issue is related to JupyterLab notebook such as

I’m using the dlinano image when I’m taking the course. Yes all that worked. This is the first problem I encountered.

I’m not sure what you are asking me to do as I’ve not changed anything after I downloaded dlinano zipped image from the link provided in the course, and burned it to a 32GB sd with Etcher. So you can accomplish the comparison by comparing the image from the course link to what you have.

I’m a newbie to this and taking the course was my attempt to start learning. I don’t have access to the Jetson Nano at the moment. Its up at my cabin and I’m not and won’t be for a few days. I took a screen shot of Jupyter when the error occurred, but I don’t see any way to upload it to the forum. Jupyter doesn’t seem to support Windows 10 standard copy/paste either so I can’t dp that either.

By the way, Edge is the only browser that will work with Jupyter. Internet Explorer does nothing and Firefox goes into an endless login loop (no, I don’t have protected browsing set). My Windows 10 has all the latest updates applied.

The issues stated in the links (or at least the solutions) are way beyond me at this stage. I don’t know what they mean!

DLI nano image is working at my end thus to answer your question, I would like to understand more about the issue you are facing. I am running Jupyter notebook on Windows 10 with Chrome browser.

Jupyter doesn’t seem to support Windows 10 standard copy/paste either so I can’t do that either.
You can enable copy/paste using shift + right click and you can get all the options.

Ok, thanks for the tip on shift/right ckick. As I said it will be later next week, probably Thursday, before I get back to the Nano again

Ok = went back up and collected the nano so here is the result:

dlinano@jetson-nano:~$ jupyter labextension list
JupyterLab v0.35.6
Known labextensions:
   app dir: /usr/local/share/jupyter/lab
        @jupyter-widgets/jupyterlab-manager v0.38.1  enabled  OK
        @jupyterlab/statusbar v0.5.0  enabled  OK
        jupyter_clickable_image_widget v0.1.0  enabled  OK

from jetcam.usb_camera import USBCamera

#TODO change capture_device if incorrect for your system
camera = USBCamera(width=224, height=224, capture_width=640, capture_height=480, capture_device=0)

image =


(224, 224, 3)



(224, 224, 3)


import ipywidgets
from IPython.display import display
from jetcam.utils import bgr8_to_jpeg

image_widget = ipywidgets.Image(format=‘jpeg’)

image_widget.value = bgr8_to_jpeg(image)


Error creating widget: could not find model

same error with a csi camera

Your JupyterLab extension list looks good. Its strange to get such error as JupyterLab does not show any broken packages.
I could not reproduce the issue you are facing even after different attempts. Also, looks like your camera is working fine, its just JupyterLab acting weird.

Can you try on your windows 10 system using the default Edge browser instead of Chrome?

ok. I tried it on Microsoft Edge, and I could reproduce your error.
For DLI nano, we suggest to use Chrome, Firefox which are supported by JupyetrLab as well. Few JupyterLab kernels are reported to be not handled well by MS Edge. Could you please try Chrome browser instead?

As I mentioned earlier Firefox doesn’t work (endless login loop). I’ll install Chrome although it’s very big brotherish and I don’t like having it on my systems. If chrome is mandatory for your tutorials to work then you need to state that and provide a download link. But really you need to work on the default browsers systems come such as Edge and Safari.

I’ll let you know if it works for me with Chrome

Ok, everything is fine with Chrome. Thanks for all your help

I have exactly the same problem as Peter. Firefox does not work, the login fails. MS Edge does not work, the widget in Jupyter notebook cannot be created (“Error creating widget: could not find model”). So I guess I have to resort to Chrome.

Yes, it works with Chrome browser for me too.

same problem here even on chrome browser. :/