[Beginner] Busy or Unavailable Device

Hello. I’m CUDA beginner. Please help me.

I was used Geforce GTX420 and GTX 660.

I was made a application with Visual Studio 2010 on Windows 7 64bit Pro.

It was working fine. Recently, I was changed board to GTX770 for better performance.

After that, some exception occured in my application.

one of them is failed cudaMalloc(). It function returns ‘cudaUnavailableDevice’.

There is nothing changed in code. I was wait until returned ‘cudaSuccess’ using while and sleep.

But, It was not working. Also, I was update graphic driver to 320.18.

I working on CUDA SDK 5.0.

Please help me. Thank you.

Try using CUDA SDK 5.5 release candidate and see if the problem is resolved?
Link: https://developer.nvidia.com/cuda-pre-production

Also make sure you’re compiling your application with compute capability 3.0, since that is the version that both the GTX 660 and GTX 770 support – Pass the following arguments to nvcc:

might as well add CC 2.0 there as well:

Thanks. vacaloca.

I tried simple test on GTX660 once again after written above.

At that time, installed driver version is 320.18.

And, it was failed. It occured same problem.

So, I tried down grade driver to ver306.94. It is default driver with CUDA Toolkit 5.0.

And, problem is solved. Lately, I was update driver from 314.22 to 320.18.

I think 314.22 was fine. I think 320.18 version has some bugs. (maybe not…)

Anyway, now I using GTX770 graphic card.

But, other driver version is not support GTX770 except 320.18.

So, my friend give to me same suggestion with yours.

I just tried test CUDA5.5 beta release, ver320.18 combination on GTX660.

It has same problem. It cause way I think driver has issus.

I didn’t try CUDA5.5 beta release, ver320.18 combination on GTX770 not yet.

I will try and write result and I hope it works…

Thank you.