New 285gtx issue - no CUDA-capable device is available message: There is no device supporting CUDA.

Hi All,

Just got a new 285GTX MAC edition today. I have a June 2008 MAC Pro, running 10.5.7 and

      boussinesq:~ johnston$ gcc -ver
      i686-apple-darwin9-gcc-4.0.1: no input files

The CUDA SDK examples do not see the card!

This is what I did

  1. installed the driver from the cd and powered off the machine

  2. removed original 8800GT card and installed the 285GTX in the same slot, along with the
    two power cables. Closed her up and rebooted.

    Under “About this Mac”, the 285gtx info correctly appears under “Graphics/Displays”

    NOTE - CUDA worked on the 8800GT!

  3. Downloaded and installed version 2.2 of SDK and Toolkit

  4. Went to /Developer/CUDA and typed “make”, which failed on imageDenoising example - reported
    duplicate entries in a library (I did not save the exact message)

  5. Found a post on this forum about this and then - reinstalled XCODE from Disc 2 that shipped with the
    MAC. Reinstalled the CUDA SDK and Toolkit.

  6. went to /Developer/CUDA and type “make” - SUCCESS this time (although numerous warnings appear!)

HOWEVER,

  1. when I try to run deviceQuery I get

boussinesq:release johnston$ ./deviceQuery
CUDA Device Query (Runtime API) version (CUDART static linking)
There is no device supporting CUDA.

Device 0: “Device Emulation (CPU)”
CUDA Capability Major revision number: 9999
CUDA Capability Minor revision number: 9999
Total amount of global memory: 4294967295 bytes
Number of multiprocessors: 16
Number of cores: 128
Total amount of constant memory: 65536 bytes
Total amount of shared memory per block: 16384 bytes
Total number of registers available per block: 8192
Warp size: 1
Maximum number of threads per block: 512
Maximum sizes of each dimension of a block: 512 x 512 x 64
Maximum sizes of each dimension of a grid: 65535 x 65535 x 1
Maximum memory pitch: 262144 bytes
Texture alignment: 256 bytes
Clock rate: 1.35 GHz
Concurrent copy and execution: No
Run time limit on kernels: No
Integrated: Yes
Support host page-locked memory mapping: Yes
Compute mode: Default (multiple host threads can use this device simultaneously)

Test PASSED

Press ENTER to exit…

  1. Other programs - scan, eigenvalues - when run report

    cudaSafeCall() Runtime API error in file <scan.cu>, line 118 : no CUDA-capable device is available. (scan)
    cudaSafeCall() Runtime API error in file <main.cu>, line 124 : no CUDA-capable device is available. (eigenvalue)

  2. Went to Nvidia site and noted a NEW DRIVER dated 6/12/09 which had to be a different version than on the
    disc that came with the card. Installed new driver, BUT STILL have the same problems - device not found.

  3. To be safe, I copied /Developer/CUDA to my Desktop, remade the SDK and again, same problem. I just
    wanted to be sure it was not a permissions thing with the codes being in /Developer/CUDA

Any ideas? I assume that the monitor can be connected to the card; I never had a problem with the 8800GT
with a monitor attached - which BTW is attached to DVI port #1 on the 285gtx.

Any help would be GREATLY appreciated.

Thanks, Hans

If kextstat | grep “CUDA” doesn’t return anything, reinstall the toolkit. When you get to the point in the installation where you can customize the installation (there is a customize button), click that and make sure CUDA.kext is selected.

Hi TMURRAY,

boussinesq:~ johnston$ kextstat | grep “CUDA”

113 0 0x8ccf1000 0x2000 0x1000 com.nvidia.CUDA (1.1.0) <5 2>

So there is a CUDA entry. Any other ideas? Could it be a problem with the card itself?

  • Hans

Hans: Might be an idea to check the card and drivers outside of CUDA.

Search for OpenGL Extensions Manager and download it, then run some of the OpenGL tests with your monitor connected to the 285. You should get numbers in the 1000s for the 1.x tests, and the Renderer Menu should show 285 OpenGL.

Can you also confirm the System info confirms Quartz Extreme and Core Image are hardware accelerated?

Hi MacFan,

I left for vacation today so can only login to the machine remotely. I recall from “About This Mac” menus that the card info was

correct and at least that Quartz Extreme was enabled.

I’ll be back in 2-3 weeks and will have to check then. I may be back in touch!

Thanks, Hans

Now I have exactly the same problems as Hans. I now am setting up a second Mac Pro 08 for CUDA, this time with an 8800GT. Have reinstalled 10.5.7, Cuda 2.2 (both driver and toolkit, including checking kext), and tried with drivers that came with 10.5.7 and the new f16 ones, and have got the same stuff:

bash-3.2$ ./deviceQuery
CUDA Device Query (Runtime API) version (CUDART static linking)
There is no device supporting CUDA.

Device 0: “Device Emulation (CPU)”
CUDA Capability Major revision number: 9999
CUDA Capability Minor revision number: 9999
Total amount of global memory: 4294967295 bytes
Number of multiprocessors: 16
Number of cores: 128
Total amount of constant memory: 65536 bytes

etc. I had no problem with the Mac 285 card at all on a different machine. This inconsistency is very odd indeed.

I have now solved this, I think. There seem to be two versions of the CUDA 2.2 drivers around. One is on the Nvidia web site and the other is on the Quadro 4800 disk. The former gives this problem and the latter does not. Nvidia might wish to update the web driver with what is shipping with the Quadro. All the problems I have on my second Mac just went away.

I am having the same problems with a 285 installed yesterday on an early 2008 Mac Pro. Very Fustrating. First my 8800GT dies 2 weeks ago, I wait for the 285 to be available instead of going with the 4870 they were trying to sell me as I wanted to update some codes I had initially implemented using CUDA on the 8800 and nothing works. Same Errors. Did they test these drivers out at all on the Mac?

I dont have a 4800, can you download the drivers from Nvidia? Will they actually install? Does it impact performance outside of CUDA?

Please would tmurray send this poster the quadro drivers asap? I do not feel able to distribute contents of cd that shipped with high value item. It would be a really good idea to make this working kext available generally.

After reverting to the drivers that shipped with the card (f8) instead of the newer f16 drivers from EVGA CUDA works just fine. Was gettin 430gflops with nbody vs. the 45.2 glfops that my gt120 was able to do.

deviceQuery says the driver version is 1,3 major,minor.

I might try to upgrade to the f16 drivers again tonight as the up to 20% improvement in performance should be noticable, but will have to revert if CUDA fails again.

http://www.xlr8yourmac.com/Graphics/mac_EV…iew/index2.html

Well, tried the f16 drivers again and they seemed to work. I think the problem for me was that I tried to install the f16 drivers from the start without first installing the f8 drivers, but they might not have had everything that came with the drivers on the cd. Anyway, installing the drivers from the CD first then installing the downloaded f16 drivers seems to have worked. All the test cases in CUDA work and the f16 drivers seem to get about a 10% speed boost over the CD drivers in games and such.

Interesting observation. In my case one of the two Pros I set up never saw the f8 drivers at all. That machine with the f16 only started to work when I did the cuda install from what was on the Quadro disk. So I agree there was maybe something missing - it now seems to be in two places!

I got my 285gtx card today and I’m having the same problem.

All of the CUDA programs say “no CUDA-capable device is available”. :-(

/Chris

I tried reinstalling the CUDA toolkit and SDK a few times and have tried the drviers that came with the card and the drivers from the EVGA.com web site, but I still get “no CUDA capable device is available”.

/Chris