BLAS / ACML issue -


I am trying to get a program up and running that usually points to BLAS. This program is ‘built’ and ‘installed’ with Python scripting commands as follows: (normally you’d do python… but BLAS is inside ACML which comes as part of PGI workstation, so extra commands are needed to point it to the right places.

python build_shlib --library-dirs=/usr/pgi/linux86-64/6.1/libso


python install

The program comes with a bunch of tests and tutorials. I can run the program and tutorials, except for the solvers (Finite element package).

When I run the solver I get errors like…

python: symbol lookup error: /usr/pgi/linux86-64/6.1/libso/
undefined symbol: ftn_str_index
ImportError: /usr/pgi/linux86-64/6.1/libso/ undefined symbol:

Any tips or suggestions:?



Hi Buddy,

While I know very little about python, the error you getting is because ACML was compiled with the pgf77 compiler and hence contains several symbols from the pgf77 runtime library. Is it possible to load the pgf77 runtime library “/usr/pgi/linux86-64/6.1/libso/” before loading “”?

  • Mat

Hi Mat,
Thanks, your tip was helpful

Here is what worked

python build_shlib --library=/usr/pgi/linux86-64/6.1/libso --blas-libraries=“pgftnrtl acml”