Bluetooth is inactive. How do I fix it?

I tried almost every suggestion that I can search from internet but none of them work.
The message from “Bluetooth window” reads “Bluetooth is disable.”

I just found that Jetson TX2 does not come with Bluetooth. Users have to add Bluetooth hardware through the M.2 key E connector/slot in order to use Bluetooth devices.

I want to unplug a Bluetooth card from an old laptop. Will it work with TX2?
Does usb Bluetooth adapter work with TX2?

Yes, it should work.

I tried a USB Bluetooth adapter last night but it could not be detected by TX2. lsusb does not show any Bluetooth device. Is it the bluetooth.conf problem?

Are you using bluetooth on M.2 slot of TX2 devkit?
lsusb misses something means the usb cannot detect the card. It is not related to any of bluetooth configuration.

I put a Bluetooth card(taking from a 4-year-old HP laptop) into the M.2 slot but it didn’t work. Then I tested 2 different generic usb Bluetooth adapters. One could be detect by lsusb but the other couldn’t. Anyway, the “System setting” shows that Bluetooth is disabled, any Bluetooth devices cannot be connected.

How do I enable it?

If your “lsusb” does not show anything, then click any button on your GUI won’t be able to enable any bluetooth. That card just somehow not able to get detected. Not related to any bluetooth…
This is just basic device detection mechanism…

We can only discuss the one card that is detected by lsusb.

Share me the dmesg and lsusb for the scenario that card is in use.

I will try it later on.

Is this card supported by TX2 ?

Not sure.

Bus 002 Device 003: ID 0bda:0411 Realtek Semiconductor Corp.
Bus 002 Device 002: ID 2109:0812 VIA Labs, Inc. VL812 Hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 006: ID 03f0:a407 Hewlett-Packard
Bus 001 Device 005: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
Bus 001 Device 004: ID 1c4f:0002 SiGma Micro Keyboard TRACER Gamma Ivory
Bus 001 Device 003: ID 0bda:5411 Realtek Semiconductor Corp.
Bus 001 Device 002: ID 2109:2812 VIA Labs, Inc. VL812 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

“Cambridge Silicon Radio” is the USB Bluetooth adapter.

Do I need to reinstall bluez?

If lsusb can see that device, then it is application layer issue, you can try to install and run bluez and see what happened.

I followed the above instruction to modify “ExecStart=/usr/lib/bluetooth/bluetoothd -d --noplugin=audio,a2dp,avrcp” to “ExecStart=/usr/lib/bluetooth/bluetoothd -d”.

And then, the Bluetooth is disabled and cannot add any devices. Devices could be added but could not be connected before.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.