Devices detected but no connection

A pair of Bluetooth earbuds is detected but could not be connected.

For information, do you observe the issue on Jetpack 4.6.4/TX2 developer kit?

What issue?

I followed the instructions on the official user guides at the first time(was Jetpack 4.6.2 or older) but only made it worse. Therefore, I do it with caution this time.

DO you use TX2 developer kit and flash system image to Jetpack 4.6.4? Or you use custom board? And please try other bluetooth devices to make sure it is not specific to the device.

Yes TX2 developer kit and updated the system to Jetpack 4.6.4.
I tried to connect a pair of earbuds(almost as good as Apple AirPods) to the system, The earbuds can be detected but cannot be connected.

Before flashing the system all over again, I tried it many times with instructions I could find on the net but no success.

I found a document which points out TX2 Devkit doesn’t come with Bluetooth, users have to add Bluetooth hardware through the M.2 key E connector/slot in order to use Bluetooth devices. However, another document shows the opposite.

Per module data sheet:
Log in | NVIDIA Developer

TX2 module has bluetooth. TX2 industrial, TX2 4GB and TX2 NX modules do not have it. It is supposed to work if you use TX2 module. That’s why we suspect it happens to specific device. We will set up 4.6.4 and try the devices we have.

Thank you.
I just figured out how to connect the Bluetooth headset/earbuds. The commands are as follows:

sudo apt-get install pulseaudio-module-bluetooth
sudo gedit /lib/systemd/system/bluetooth.service.d/nv-bluetooth-service.conf

and then remove any words behind “ExecStart=/usr/lib/bluetooth/bluetoothd -d”.

I did it before flashing the system all over again but no use. However, it works this time. This is most likely because I tried a lot of commands that made the Bluetooth config/system files corrupted. And this time, I only used above method.

The system is updated to Jetpack 4.6.4 is probably another reason.

1 Like

I turned on the TX2 tonight and found that the Bluetooth doesn’t work again! It worked last time(5 days ago). I haven’t changed anything or keyed in any commands except “sudo apt-get update”.