Jetson Xavier NX not booting up after changing bluetooth configuration

Case:
I tried to connect to a bluetooth speaker to play audio. The pairing was successful, however, I could not establish connection with the device.

I followed these instructions to try and solve the bluetooth problem:

https://docs.nvidia.com/jetson/l4t/#page/Tegra%20Linux%20Driver%20Package%20Development%20Guide/asoc_driver.19.2.html#wwpID0E03W0HA

Note: I realized after following the instructions that it specifies that “Applies to: Original Jetson TX2 only”

Problem:
The device does not boot up, or at least the screen is blank.

Observations:

  1. I am using the original power supply
  2. Power LED is ON (not blinking)
  3. I have a mouse with LEDs that light up when mouse is connected. Now, the mouse is not lighting up in either of the 4 usb ports

I have tried:

  1. Flashed a new SD card with fresh JetPack4.5 image (jetson-nx-jp451-sd-card-image) and still the screen is blank when I boot the device and no power coming from the USB ports
  2. Tried to connect to the device through the Micro USB but it is not recognized (Windows 10)

Is there anything else I can do?

Hi edwardfer.96,

What kind of bluetooth device are you use?
Please provide the UART log for check. Thanks!

My main concern was that my jetson device was not booting up and ports were unresponsive when I rebooted the device after following the instructions to enable the bluetooth audio.

I wanted to provide the UART log but I was not able to detect the jetson from any host. Finally after trying 6 different cables (no cable was provided with the jetson xavier nx kit), I was able to detect the device. I reflashed the SD card through the SDK manager and everything went back to normal.