Jetson Xavier NX ports are not working

I have been using the device for a week now and have rebooted several times without any problem. Last time I rebooted the device, it never booted again.

When I connect the power to the device, the power LED turns on, however, the screen is blank as if the device never boots. I have tried both HDMI and DisplayPort.

I believe the following ports are not working:

  1. HDMI
    My monitor does not detect any signal.

  2. DisplayPort
    My monitor does not detect any signal.

  3. USB3.0 (all 4 of them)
    I have a device that turns a LED ON whenever it was connected to any of the Jetson’s 4 USB ports. Now, this device’s LED does NOT turn on when connected to any of them.

  4. Ethernet
    My router configuration site does not show the device even if it is connected directly to the router with the ethernet cable. Other devices do show up when connected with the cable.

  5. Micro USB
    My pc does not recognize the device when it is connected.
    – I’m in Ubuntu20.04
    – The command lsusb lists all connected devices but NOT the Jetson
    – I have been trying to debug using the serial console to determine what is wrong, but since my pc does not recognize the device I cannot read from it

Ports that seem to be working:

  1. CAM0 and CAM1
    I have a camera module that has an LED that turns on when connected. This LED turns on as expected when connected to any of these ports.

I flashed a new SD card with JetPack4.5 but the device remains in the same state as described above.

  1. Please flash your board with sdkmanager but not sdcard image.

  2. If the flash process cannot work, dump the log from serial console which will show the boot log from your NX.
    Jetson Nano - Serial Console - JetsonHacks

  3. If no boot log is shown and you cannot flash the board, then please RMA this device.

Flashing the board with sdkmanager was the solution. Although I want to emphasize that I was already trying to do that, but my main problem was that the host could not detect the device.

The real solution was to try different micro USB cables until I found one that worked.

1 Like