Blurry/out-of-focus graphics on Plasma 5.15 with NVIDIA driver 418

When I was still using Kubuntu 18.10 with Plasma 5.15 (installed from backports repo) the blurry/out-of-focus thing only happens after waking up from sleep. Now, with Kubuntu 19.04 beta, it happens all the time. I also tried this with KDE Neon (user edition) with same results. This doesn’t happen with Nouveau driver or on my laptop with Intel driver.

Here’s a sample video of it. It’s no longer as crazy after enabling flipping, but it still happens frequently enough that it gets annoying.

Operating System: Kubuntu 19.04
KDE Plasma Version: 5.15.4
KDE Frameworks Version: 5.56.0
Qt Version: 5.12.2
Kernel Version: 5.0.0-8-generic
OS Type: 64-bit
Processors: 4 × Intel® Core™ i5-6500 CPU @ 3.20GHz
Memory: 15.6 GiB of RAM
GPU: GTX 1060 6GB
nvidia-bug-report.log.gz (1.13 MB)

Please check if this is caused by ForceCompositionPipeline by disabling it.

It’s not. It still happens even with ForceCompositionPipeline disabled.

I’m actually on a fresh install. Thought that might help fix it.

Which render-backend of kwin are you using? Does changing this changes anything on the situation?

Tried with both OpenGL 2.0 & 3.0

Using XRender removes the issue. I know that’s defeating the purpose, but it points to something in the OpenGL processing being squiffy. Not a programmer so no idea what. But my screen was terrible on both openGL modules. So it has to be the way they are processed or something common to them both that is not common to Xrender.

Also on OpenGL 2./3. the blurry only happens where the screen is not being redrawn, if you hover the mouse or move the mouse through an area, or type, it sharpens up near the cursor.
Maybe there is some kind of drift in the way its cheating to improve performance by reducing what it has to reprocess to display. Maybe forcing complete redraws may fix the blur problem but increase CPU load??? Just thinking out loud.

Did you figure out a solution to this? After a recent update I have the exact same problem from KDE Neon with an RTX 2070