Weird KDE/KWIN Bug

There seems to be some weird bug plaguing any driver above 465.xx, if you have “Allow Flipping” set to on the entire KWIN session starts to lag every time you open settings or a browser or something in general. Disabling flipping will fix the desktop, but then stuff like GSync and ForceCompositionPipeline wouldn’t work which isn’t ideal solution…

EDIT: It seems like I am not the only one experiencing this -
You will normally see a change in mouse stutter and your cursor should not "skip" frames when launching apps. that’s the kind of frameskip/framedrop that’s happening.

I am having this same issue on 525.60.11 with the RTX 4090. Everything stutters, including running video, every time I open an application.

Disabling flipping and enabling compositor pipeline causes other issues.

This is a problem that has existed for years as far as I know. This is why the KDE Plasma/X11 session is so bad for NVIDIA cards. I don’t think it will get better after this time. The only solution is to use the Wayland session. But there are missing features for Wayland on NVIDIA side. If these are not important to you you can use the Wayland session.

True, this doesn’t happen in wayland, but from what it looks like, there are a lot of other problems on wayland. I hope they fix the stutter on x11, but I doubt they will if it’s been around for years.

X11 is a dead project. Wayland is the future. Your expectation from now on should be for NVIDIA to make Wayland as complete as possible.

Wayland is the future, but x11, although dead, is the present. When I was testing it yesterday, I found way too many issues with application and scaling support on wayland, including the mouse cursor being giagantic on HDPI. Especaially on applications designed with x in mind. Plus a lot of graphical artifacts in the UI/UX. Maybe wayland will be the present technology in a few years. It’s not currently though. The stuff that people are currently using should work.

Either way, that means presently, nvidia doesn’t have a driver that works properly on KDE plasma. They really should, apparently their competition does. Maybe I’ll try out something lesser, like xfce, and see how that works. I like plasma though.

There is a way to sort of mitigate KDE/KWIN to make it work good.
In the nvidia config you need the following two options(right after you have enabled ForceCompositionPipeline).

    Option         "ForceFullCompositionPipeline" "on"
    Option         "UseNvKmsCompositionPipeline" "false"
    Option         "TripleBuffer" "on"

UseNvKmsCompositionPipeline set to false, means that it will use the previous composition pipeline and with triple buffer on it sort of mitigates the issue above, but I see this as a workaround rather than a full fix. Even though the workaround makes it highly smooth, it could still have occasionally a frame skip, but at least it’s much less than without it.

Thanks, I have tired those settings except UseNvKmsCompositionPipeline. Which I just tried. Maybe it was a fluke, but It wouldn’t boot back into SDDM when I tried to restart.

A few days ago when I noticed this problem, I was able to smooth the desktop out quite a bit with the composition pipeline stuff and triple buffering, but I noticed that gaming performance became quite stuttery. Despite frame-times being flat.

I will play with disabling the KmsCompositionPipeline again when I am feeling braver.