Bootloader Update Failed

Hi,Nvidia
I tried upgrading the bootloader using the official method, and the steps are as follows:

[Host]
$ sudo ./l4t_generate_soc_bup.sh t23x
$ ./generate_capsule/l4t_generate_soc_capsule.sh -i bootloader/payloads_t23x/bl_only_payload -o ./TEGRA_BL.Cap t234
$ scp TEGRA_BL.Cap nvidia@<IP address>:/home/nvidia/.

[Target]
$ ll /dev/disk/by-partlabel/esp
$ sudo mount /dev/mmcblk0p10 /mnt/
$ cd /mnt/EFI
# mkdir UpdateCapsule
# cd UpdateCapsule/
# cp /home/nvidia/TEGRA_BL.Cap .
# cd /sys/firmware/efi/efivars/
# printf "\x07\x00\x00\x00\x04\x00\x00\x00\x00\x00\x00\x00" > /tmp/var_tmp.bin
# sudo dd if=/tmp/var_tmp.bin of=OsIndications-8be4df61-93ca-11d2-aa0d-00e098032b8c bs=12
# reboot

After restarting, enter the following command:

nvbootctrl -t bootloader dump-slots-info

Found Capsule update status as 0,


How should this be resolved?
The version of BSP is R35-3

Hi shuochong.liu,

Are you using the devkit or custom board for AGX Orin?

Is it your original BSP release?
What’s your target release?

Current version: 0.0.1

Do you customize this version so that it shows 0.0.1?

I am using custom board.

Yes,it is original version.I modify bootloader,so i want to update it.

No, I don’t know why it’s showing 0.0.1.
I ran cat /etc/nv_tegra-release and the display was correct

Is there any error when you are generating package for capsule update?

Please also share the log after you run reboot command.
Actually, you should see update status bar in UEFI after you run reboot command.

The log for generating BUP is as follows:
generate_soc_bup.txt (2.3 MB)

The log for generating the capsule is as follows:
generate_capsule_payload.txt (2.7 KB)

The log after rebootis as follows:
reboot.txt (124.4 KB)

What do you modify in bootloader?

????Shutdown state requested 1
Rebooting system ...
??
[0000.060] I> MB1 (version: 0.32.0.0-t234-54845784-57325615)

From your log, it seems something causing it shutdown in UEFI, and I don’t see any update log.
The current UEFI is not the official image, I think it has been updated by you before.

Do you have the devkit to verify the same workflow?

I just added some printing.

No,i do not have devkit.

Can the upgrade of boot loader only be done to the released version?
If some content is modified in the same release version, upgrading is not supported, is it

You can perform capsule update for bootloader to the same release as the original version.