Bug in nVidia driver on dual-processor machines


I (believe I have) found a nasty bug in nVidia drivers occuring when using OpenGL on a dual processor machine.

Please find the repro code to be run under Eclipse Java here:


(The above link is a URL shortener and will let you see the actual link it points to before downloading the file).

I use LWJGL through a Maven dependency so that you don’t have anything to do except run my sample code.

When run on virtually any system, the first call to glMapBufferRange is completed in about 1 millisecond.

When run on the setup below, the same function is run in 15 seconds. This is clearly a bug to me.

I tried multiple drivers (461.72, 461.92 being the latest) as well as multiple graphics cards (Titan V, 1080Ti, RTX 2080) and the problem always remains.

The problematic setup is the following :

Dell Precision 7920T Workstation
Latest BIOS installed
NUMA mode enabled in BIOS
Fresh install of Windows 10 x64 Professional for Workstations, version 20H2 19042.867
All updates installed.
nVidia drivers 461.72 or 461.92. I had tried older versions of the driver but the problem remains.

Thanks for your help,