Bug report: 8400M GS + Win7 errors errors and more errors

Hardware: Core2 Duo, 4gigs ram, 8400M GS
OS: Windows 7 - 64bit
Driver version: 195.62 (WHQL)

Almost every cuda application I run (except the device query CUDA sample programs, which return exactly what you’d expect) returns varying CUDA errors, when they shouldn’t return any at all.

As I said, device query returns completely valid/correct data - no errors/warnings reported.
bandwidthTest / volumeRender / etc (‘all’ of the CUDA samples) return errors, generally ‘out of memory’ or ‘no cuda-capable device’.
(Note: The samples I ran were 32bit samples, not 64bit - but we specifically require running 32bit apps on 64bit OS for windows…)

Similarly, our own apps tend to get CUDA_ERROR_OUT_OF_MEMORY or CUDA_ERROR_UNKNOWN when simply creating a CUDA context (cuCtxCreate and cuGLCtxCreate), and in the odd ocassion that they don’t - simply loading a kernel module (cuModuleLoadFatBinary / cuModuleLoad) will reliably return CUDA_ERROR_OUT_OF_MEMORY.

Is this a known bug? Has anyone else experienced these problems with older hardware? Can anyone confirm this bug?

Much thanks in advance, this is a pretty serious issue for us. (And a worrying one at that, our QA guys are considering not passing any of our CUDA apps through to stable releases at present…)