By creating the xorg.conf file the xorg freezes 550, 535 series

Hi, by creating the /etc/X11/xorg.conf file, running sudo nvidia-xconfig and reboot my computer. When I’m hitting startx the xorg freezes. So I have to remove them manually sudo rm /etc/X11/xorg.conf and sudo rm /etc/X11/xorg.conf.nvidia-xconfig-original files to see graphics again

nvidia-bug-report-log.tar.gz (966.4 KB)

Test it on:

OS: Arch Linux x86_64
Host: Dell G3 3779
Kernel: 6.8.2-zen2-1-zen
Shell: bash 5.2.26
Resolution: 1920x1080
Desktop: Xfce 4.18
Window Manager: Xfwm4
Terminal: xfce4-terminal
CPU: Intel i7-8750H (12) @ 4.100GHz
GPU: Intel CoffeeLake-H GT2 [UHD Graphics 630]
GPU: NVIDIA GeForce GTX 1050 Ti
NVIDIA Driver: 550.67 (Include bug report)
NVIDIA Driver: 535.171.04 (Include bug report)

PS: Possibly is not working for 545 series. I’m referring especially for proprietary driver not the open source

It’s a hybrid graphics notebook, the nvidia gpu is secondary gpu. Why the heck are you creating an xorg.conf, it’s 2024, not 2007.

1 Like

At very first time that I created the xorg.conf, I didn’t know why xorg didn’t start. I was lucky because I didn’t installed any display manager. Maybe needs more investigation how Intel CoffeeLake-H GT2 [UHD Graphics 630] and NVIDIA GeForce GTX 1050 Ti are involved together.

nvidia-xconfig creates Xorg config files, which are not compatible with hybrid systems.
It’s a shame Nvidia does not update it to a current state, or at least have it print an error/warning message when run on an optimus laptop. As you are by far not the only unsuspecting user running into that trap.

Rule of thumb: never create an xorg.conf. This has become something like a cargo cult, getting more ridiculous year by year. There are only very, very few special setups where you actually need to create one now.
For using hybrid graphics on Arch, either use render offload or set the nvidia gpu as primary gpu.
https://wiki.archlinux.org/title/PRIME#PRIME_render_offload
https://wiki.archlinux.org/title/NVIDIA_Optimus#Use_NVIDIA_graphics_only

I’m on NVIDIA/Troubleshooting so your help is appreciated.

@generix I have already did theses steps when I’m hitting startx the xorg is not freezing but I got black screen.
Use_NVIDIA_graphics_only

Since you’re not using GDM/Gnome, you’ll have to add the xrandr commands to your DM’s config. Which are you using?

I have disabled DM to be safe. I’m using lightdm.

So did you add the xrandr commands to ~/.xinitrc or /etc/X11/xinit/xinitrc for startx and the to lightdm config?

Yes I have added the xrandr commands in to ~/.xinitrc and I got black screen. I have disabled lightdm to use startx insted.

Please create a new nvidiq-bug-report.log

nvidia-bug-report.log.gz (503.6 KB)

The xrandr commands didn’t trigger.

The xrandr commands didn’t trigger because of this:
In to ~/.xinitrc i did

exec startxfce4
xrandr --setprovideroutputsource modesetting NVIDIA-0
xrandr --auto

to be trigger you must add xrandr commands before the exec startxfce4

xrandr --setprovideroutputsource modesetting NVIDIA-0
xrandr --auto
exec startxfce4

Thank you for your help

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.